aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/log4cpp
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2016-02-23 13:45:32 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:47:29 +0100
commit9ab06ee695c2e2b688f2ddd83ef32852cf441082 (patch)
tree02b8c8c252ba8fbff10f5d7f26f7bc077176c689 /meta-oe/recipes-support/log4cpp
parentdb304d23d598ef6fb04d32a0d5c42485fc7b1872 (diff)
downloadmeta-openembedded-contrib-9ab06ee695c2e2b688f2ddd83ef32852cf441082.tar.gz
log4cpp: Fix build system path in pkgconfig file QA failure.
* Must remove path from pc.in and stop configure.in from regenerating the file. * Also included some changes requested in earlier review that arrived late. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/log4cpp')
-rw-r--r--meta-oe/recipes-support/log4cpp/files/fix-pc.patch20
-rw-r--r--meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb8
2 files changed, 25 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/log4cpp/files/fix-pc.patch b/meta-oe/recipes-support/log4cpp/files/fix-pc.patch
new file mode 100644
index 0000000000..b8fb42e5fd
--- /dev/null
+++ b/meta-oe/recipes-support/log4cpp/files/fix-pc.patch
@@ -0,0 +1,20 @@
+diff -Nurd ./log4cpp.orig/configure.in ./log4cpp/configure.in
+--- ./log4cpp.orig/configure.in 2009-09-07 16:57:46.000000000 -0400
++++ ./log4cpp/configure.in 2016-02-23 12:57:11.567240018 -0500
+@@ -130,7 +130,6 @@
+ # ----------------------------------------------------------------------------
+
+ AC_CONFIG_LIBCONFIG_IN([log4cpp])
+-AC_CONFIG_PKGCONFIG_IN([log4cpp], [C++ library for flexible logging, modeled after Log4j])
+
+ AC_CONFIG_FILES([
+ Makefile
+diff -Nurd ./log4cpp.orig/log4cpp.pc.in ./log4cpp/log4cpp.pc.in
+--- ./log4cpp.orig/log4cpp.pc.in 2004-01-27 05:24:25.000000000 -0500
++++ ./log4cpp/log4cpp.pc.in 2016-02-22 15:06:55.769327491 -0500
+@@ -7,4 +7,4 @@
+ Description: C++ library for flexible logging, modeled after Log4j
+ Version: @VERSION@
+ Libs: -L${libdir} @log4cpp_libs@
+-Cflags: -I${includedir} @log4cpp_cflags@
++Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
index a543044162..c7bf288fab 100644
--- a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
+++ b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
@@ -6,9 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI[md5sum] = "1e173df8ee97205f412ff84aa93b8fbe"
SRC_URI[sha256sum] = "35abf332630a6809c969276b1d60b90c81a95daf24c86cfd7866ffef72f9bed0"
-SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz"
+SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz \
+ file://fix-pc.patch;striplevel=2 \
+ "
-S="${WORKDIR}/${BPN}"
+S = "${WORKDIR}/${BPN}"
inherit autotools pkgconfig
@@ -17,5 +19,5 @@ EXTRA_OECONF = "\
--enable-dot=no \
--enable-html-docs=no \
--enable-latex-docs=no \
- LDFLAGS=-lpthread \
+ LDFLAGS=-pthread \
"