aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lockdev
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 17:57:10 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-20 16:07:50 -0800
commit89461fecb74a9e110e4c7d6d0878e2f7f0eac1e4 (patch)
tree44e78df61dc5bd75bd1e9dd7a0b52450d76c92cc /meta-oe/recipes-support/lockdev
parent5a5d2cfa1b4f98b4f369ced54c0a9d03dcda1468 (diff)
downloadmeta-openembedded-contrib-89461fecb74a9e110e4c7d6d0878e2f7f0eac1e4.tar.gz
lockdev: Make baselib configurable
This ensures that baselib can be passed from bitbake tasks via environment Refresh patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lockdev')
-rw-r--r--meta-oe/recipes-support/lockdev/lockdev/build.patch2
-rw-r--r--meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch8
-rw-r--r--meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb6
3 files changed, 9 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/lockdev/lockdev/build.patch b/meta-oe/recipes-support/lockdev/lockdev/build.patch
index 6ec91d2316..f9fe48b2a6 100644
--- a/meta-oe/recipes-support/lockdev/lockdev/build.patch
+++ b/meta-oe/recipes-support/lockdev/lockdev/build.patch
@@ -18,7 +18,7 @@ Date: Tue Feb 9 14:56:23 2010 +0100
soname = ${libname}.so.${MVER}
# overwritten by caller (e.g.: debian/rules)
-@@ -72,6 +72,7 @@ install_doc: docs/lockdev.3
+@@ -73,6 +73,7 @@ install_doc: docs/lockdev.3
install_run: ${shared}
install -m755 -d ${libdir}
install -m644 ${shared} ${libdir}
diff --git a/meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch b/meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch
index aa8f6a4d85..aa8b0f6923 100644
--- a/meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch
+++ b/meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch
@@ -1,14 +1,16 @@
--- a/Makefile
+++ b/Makefile
-@@ -15,17 +15,17 @@ shared = ${libname}.${VER}.so
+@@ -15,17 +15,18 @@ shared = ${libname}.${VER}.so
soname = ${libname}.so.${MVER}
# overwritten by caller (e.g.: debian/rules)
-basedir = /usr/local
+basedir ?= /usr/local
++baselib ?= lib
srcdir=.
- libdir = ${basedir}/lib
+-libdir = ${basedir}/lib
++libdir = ${basedir}/${baselib}
incdir = ${basedir}/include
mandir = ${basedir}/share/man
@@ -17,7 +19,7 @@
-CFLAGS = -g
-LDLIBS = -llockdev
+CC ?= gcc
-+LCFLAGS ?= -g -O2 -fPIC -Wall -pipe -D_REENTRANT
++LCFLAGS ?= -g -O2 -fPIC -Wall -pipe -D_REENTRANT
+CFLAGS ?= -g
+LDLIBS ?= -llockdev
diff --git a/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb b/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
index 5b862bd1fe..9d8800ebde 100644
--- a/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
+++ b/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
@@ -15,15 +15,15 @@ SRC_URI[debianpatch.md5sum] = "5ef6267c42fca9145e0af006ccb6aff7"
SRC_URI[debianpatch.sha256sum] = "a5405c6ee5e97e45eeb1c81330a7e9f444a58bda5e6771fa30007516c115007e"
inherit lib_package perlnative
-export basedir="${D}${prefix}"
CFLAGS += " -D__GNU_LIBRARY__"
TARGET_CC_ARCH += "${LDFLAGS}"
+EXTRA_OEMAKE = "basedir=${D}${prefix} baselib=${baselib} LD='${CC}' LD='${CC}'"
do_compile() {
- oe_runmake basedir=${D}${prefix} LD="${CC}" LD="${CC}" shared static
+ oe_runmake shared static
}
do_install() {
- oe_runmake DESTDIR=${D} basedir=${D}${prefix} install
+ oe_runmake DESTDIR=${D} install
}