aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lio-utils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-21 18:23:47 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commitfb83b5d110616cb09332ec8be6e4c6209f64d85e (patch)
treec5dcc1a9a49a14a1a81279efb485b2792248b06f /meta-oe/recipes-support/lio-utils
parent9322d09dc4030b32d930a03359254386a2b2b0d1 (diff)
downloadmeta-openembedded-contrib-fb83b5d110616cb09332ec8be6e4c6209f64d85e.tar.gz
lio-utils: Make it visible only with meta-py2 in BBFILE_COLLECTIONS
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lio-utils')
-rw-r--r--meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
index 058117ed83..8e5986bd9e 100644
--- a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
+++ b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Datera/lio-utils.git \
SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e"
S = "${WORKDIR}/git"
-inherit distutils3
+inherit distutils
EXTRA_OEMAKE += "DESTDIR=${D}"
@@ -64,3 +64,9 @@ FILES_${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*"
# http://errors.yoctoproject.org/Errors/Details/184712/
# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
CLEANBROKEN = "1"
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
+