aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2015-01-09 11:01:08 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-12 15:34:01 +0100
commitda4dab68d601b9bd2903f761f043f0d438033bd5 (patch)
tree78db6905b7be503e0e81f8f63658e3cd13bdd908 /meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
parenta5e8a79f04164d63e1a87f495c3dd766bd7b6df8 (diff)
downloadmeta-openembedded-contrib-da4dab68d601b9bd2903f761f043f0d438033bd5.tar.gz
libutempter: Fix compile error
| iface.c: In function 'utempter_add_record': | <command-line>:0:12: error: expected expression before '/' token | iface.c:46:35: note: in expansion of macro 'LIBEXECDIR' | #define UTEMPTER_DEFAULT_PATHNAME LIBEXECDIR "/utempter/utempter" Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb')
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb b/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
index 30a68961d2..f84e6493c7 100644
--- a/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
+++ b/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
@@ -7,16 +7,17 @@ SECTION = "System Environment/Libraries"
LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
-SRC_URI = "ftp://ftp.altlinux.org/pub/people/ldv/utempter/${BP}.tar.bz2"
+SRC_URI = "ftp://ftp.altlinux.org/pub/people/ldv/utempter/${BP}.tar.bz2 \
+ file://0001-Fix-macro-error.patch"
SRC_URI[md5sum] = "b43827806923903aba2bc7cd3a2d45b7"
SRC_URI[sha256sum] = "b898565f31ced7e5c1fa0a2eaa0f6ff0ed862b5fe375d26375b64bfbdfeac397"
-CFLAGS += "-DLIBEXECDIR=$(libexecdir)"
+CFLAGS += "-DLIBEXECDIR=${libexecdir}"
do_compile() {
oe_runmake \
libdir=${libdir} \
- libexecdir=${libexecdir} \
+ libexecdir=${libexecdir}
}
do_install() {
@@ -27,10 +28,9 @@ do_install() {
includedir=${includedir} \
mandir=${mandir}
- rm -f ${D}${libdir}/*.a
+ rm -f ${D}${libdir}/*.a
}
FILES_${PN} = "${libdir}/*.so.*"
FILES_${PN} += "${libexecdir}/utempter/utempter"
-
FILES_${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"