aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-04 10:45:55 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-05 09:45:50 -0700
commit7724eab259491cf283ed661d36e13ccfb1a3d653 (patch)
tree0aea9aa6db88d511a3b5db1216af3447478dfeed /meta-oe/recipes-support/liburing
parent4fe10656553bc4afa293796c57ae99c728937ada (diff)
downloadmeta-openembedded-contrib-7724eab259491cf283ed661d36e13ccfb1a3d653.tar.gz
liburing: Upgrade to 2.0
- Remove upstreamed 0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch - Fix for removal of SIGSTKSZ - Forward remaining patches - Fix tests on arm/riscv32 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing')
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch10
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch37
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch35
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch53
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.0.bb (renamed from meta-oe/recipes-support/liburing/liburing_0.7.bb)5
5 files changed, 98 insertions, 42 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch b/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch
index 19bf14708b..03ab075314 100644
--- a/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch
+++ b/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch
@@ -1,4 +1,4 @@
-From 3ee2f1e231bde18a99f86da747a9b8feca3c179d Mon Sep 17 00:00:00 2001
+From 653c39b0b30b2a329db5041e558cfc97c03d6bfb Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 17 Feb 2021 19:18:16 -0800
Subject: [PATCH] do not build examples
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 948e004..8b63024 100644
+index 5d9c4dc..53e1615 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,6 @@ default: all
@@ -23,8 +23,8 @@ index 948e004..8b63024 100644
@$(MAKE) -C test
- @$(MAKE) -C examples
- partcheck: all
- @echo "make partcheck => TODO add tests with out kernel support"
+ .PHONY: all install default clean test
+ .PHONY: FORCE cscope
--
-2.30.1
+2.31.1
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch b/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch
new file mode 100644
index 0000000000..a2ba66c3ab
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch
@@ -0,0 +1,37 @@
+From a30d62dfb9ea30af58ef331fae1e6f727d0558c0 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 4 May 2021 10:32:08 -0700
+Subject: [PATCH] examples/ucontext-cp.c: Do not use SIGSTKSZ
+
+glibc 2.34 has removed SIGSTKSZ therefore we replace it
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ examples/ucontext-cp.c | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+--- a/examples/ucontext-cp.c
++++ b/examples/ucontext-cp.c
+@@ -3,6 +3,7 @@
+ * gcc -Wall -O2 -D_GNU_SOURCE -o ucontext-cp ucontext-cp.c -luring
+ */
+ #define _POSIX_C_SOURCE 199309L
++#include <stddef.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <string.h>
+@@ -22,13 +23,9 @@
+ #define QD 64
+ #define BS 1024
+
+-#ifndef SIGSTKSZ
+-#define SIGSTKSZ 8192
+-#endif
+-
+ typedef struct {
+ struct io_uring *ring;
+- unsigned char stack_buf[SIGSTKSZ];
++ max_align_t stack_buf[(8 * 1024 + sizeof (max_align_t) - 1) / sizeof (max_align_t)];
+ ucontext_t ctx_main, ctx_fnew;
+ } async_context;
+
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch b/meta-oe/recipes-support/liburing/liburing/0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch
deleted file mode 100644
index 01c5ccd53a..0000000000
--- a/meta-oe/recipes-support/liburing/liburing/0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 0a9b12eda0f6e487398dad004121bdd1be792428 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 14 Nov 2020 16:18:44 -0800
-Subject: [PATCH] test: Fix build on 32bit architectures with 6bit time_t
-
-It uses SYS_futex, which it expects from system C library.
-in glibc (/usr/include/bits/syscall.h defines it in terms of of NR_futex)
-rv32 is using 64bit time_t from get go unlike other 32bit architectures
-in glibc, therefore it wont have NR_futex defined but just NR_futex_time64
-this aliases it to NR_futex so that SYS_futex is then defined for rv32
-
-Upstream-Status: Submitted [https://github.com/axboe/liburing/pull/237]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- test/35fa71a030ca-test.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/test/35fa71a030ca-test.c b/test/35fa71a030ca-test.c
-index 4ecf211..7f2124b 100644
---- a/test/35fa71a030ca-test.c
-+++ b/test/35fa71a030ca-test.c
-@@ -24,6 +24,10 @@
-
- #include <linux/futex.h>
-
-+#if !defined(SYS_futex) && defined(SYS_futex_time64)
-+# define SYS_futex SYS_futex_time64
-+#endif
-+
- static void sleep_ms(uint64_t ms)
- {
- usleep(ms * 1000);
---
-2.29.2
-
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch b/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch
new file mode 100644
index 0000000000..f2f03c18b4
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch
@@ -0,0 +1,53 @@
+From 2d3940163e14d183fddc4d8b24cc1d3865bba0b3 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 5 May 2021 09:36:36 -0700
+Subject: [PATCH] tests: fix portability issue when using __NR_mmap syscall
+
+On some architectures e.g. ARM and RISCV32, __NR_mmap does not exist and
+libc will then use NR_mmap2 to implement mmap() API, therefore use
+system C library mmap() API instead of calling the syscall directly
+
+Upstream-Status: Partial Backport [https://github.com/axboe/liburing/commit/808b6c72ab753bda0c300b5683cfd31750d1d49b]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ test/double-poll-crash.c | 6 +++---
+ test/sqpoll-disable-exit.c | 6 +++---
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/test/double-poll-crash.c b/test/double-poll-crash.c
+index 1a219c7..6e08285 100644
+--- a/test/double-poll-crash.c
++++ b/test/double-poll-crash.c
+@@ -150,9 +150,9 @@ int main(int argc, char *argv[])
+ if (argc > 1)
+ return 0;
+
+- syscall(__NR_mmap, 0x1ffff000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul);
+- syscall(__NR_mmap, 0x20000000ul, 0x1000000ul, 7ul, 0x32ul, -1, 0ul);
+- syscall(__NR_mmap, 0x21000000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul);
++ mmap((void *) 0x1ffff000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
++ mmap((void *) 0x20000000, (size_t) 0x1000000, PROT_READ | PROT_WRITE | PROT_EXEC, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
++ mmap((void *) 0x21000000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
+ intptr_t res = 0;
+ *(uint32_t*)0x20000484 = 0;
+ *(uint32_t*)0x20000488 = 0;
+diff --git a/test/sqpoll-disable-exit.c b/test/sqpoll-disable-exit.c
+index d4e17f8..a0d00cc 100644
+--- a/test/sqpoll-disable-exit.c
++++ b/test/sqpoll-disable-exit.c
+@@ -223,9 +223,9 @@ void execute_one(void)
+ }
+ int main(void)
+ {
+- syscall(__NR_mmap, 0x1ffff000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul);
+- syscall(__NR_mmap, 0x20000000ul, 0x1000000ul, 7ul, 0x32ul, -1, 0ul);
+- syscall(__NR_mmap, 0x21000000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul);
++ mmap((void *) 0x1ffff000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
++ mmap((void *) 0x20000000, (size_t) 0x1000000, PROT_READ | PROT_WRITE | PROT_EXEC, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
++ mmap((void *) 0x21000000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0);
+ loop();
+ return 0;
+ }
+--
+2.31.1
+
diff --git a/meta-oe/recipes-support/liburing/liburing_0.7.bb b/meta-oe/recipes-support/liburing/liburing_2.0.bb
index d79389a696..9eddf2e2a5 100644
--- a/meta-oe/recipes-support/liburing/liburing_0.7.bb
+++ b/meta-oe/recipes-support/liburing/liburing_2.0.bb
@@ -10,12 +10,13 @@ LICENSE = "LGPLv2.1 | MIT"
LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
- file://0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch \
+ file://0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch \
+ file://0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch \
"
SRC_URI_append_libc-musl_riscv64 = " file://0001-do-not-build-examples.patch "
SRC_URI_append_libc-musl_riscv32 = " file://0001-do-not-build-examples.patch "
-SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e"
+SRCREV = "b013dfd5a5f65116373d5e0f0bdfb73db9d8816e"
S = "${WORKDIR}/git"
DEPENDS_append_libc-musl = " libucontext"