aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing/liburing_2.1.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-10-29 12:25:03 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commit2dd1a2f2a9730326a4b1b32f6246ae93178906eb (patch)
tree5ce34e2781aa9755957b68b2740823b1a4f4ca49 /meta-oe/recipes-support/liburing/liburing_2.1.bb
parentb66ad223244977acd2ec38ab38b7ed896fb80429 (diff)
downloadmeta-openembedded-contrib-2dd1a2f2a9730326a4b1b32f6246ae93178906eb.tar.gz
liburing: update to 2.1
Removed upstreamed patcches. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing/liburing_2.1.bb')
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing_2.1.bb b/meta-oe/recipes-support/liburing/liburing_2.1.bb
new file mode 100644
index 0000000000..b4f0b11f4e
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing_2.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "This is the io_uring library, liburing."
+DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
+instances, and also a simplified interface for applications that don't need \
+(or want) to deal with the full kernel side implementation."
+HOMEPAGE = "https://github.com/axboe/liburing"
+BUGTRACKER = "https://github.com/axboe/liburing/issues"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1 | MIT"
+LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
+
+SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
+SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
+SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
+SRCREV = "41a61c97c2e3df4475c93fdf5026d575ce3f1377"
+
+S = "${WORKDIR}/git"
+
+DEPENDS:append:libc-musl = " libucontext"
+XCFLAGS = "-pthread"
+XCFLAGS:append:libc-musl = " -lucontext"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
+do_configure() {
+ ${S}/configure --prefix=${prefix}
+}
+do_install () {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
+}