aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libtinyxml2
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-04-05 23:23:13 -0700
committerKhem Raj <raj.khem@gmail.com>2023-04-06 13:45:01 -0700
commit8b0fe7a1d1e485befed2f4abedcaf6c6c8822b0e (patch)
tree59f4612aff92f65cf52ffb2fdd5bb0e244b82bf5 /meta-oe/recipes-support/libtinyxml2
parent3e4121b6e7192b2d98fdd533d5ca8270914f5589 (diff)
downloadmeta-openembedded-contrib-8b0fe7a1d1e485befed2f4abedcaf6c6c8822b0e.tar.gz
libtinyxml2: Add ptest support
- Switch to usong meson build system - Fix build with musl by defining _LARGEFILE64_SOURCE Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libtinyxml2')
-rw-r--r--meta-oe/recipes-support/libtinyxml2/files/run-ptest10
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb18
2 files changed, 23 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/files/run-ptest b/meta-oe/recipes-support/libtinyxml2/files/run-ptest
new file mode 100644
index 0000000000..870912672e
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/files/run-ptest
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+for i in `ls xmltest`; do
+ ./$i
+ if [ $? -eq 0 ]; then
+ echo "PASS: $i"
+ else
+ echo "FAIL: $i"
+ fi
+done
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
index 7f205987f4..7ef4d89ce0 100644
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
@@ -4,14 +4,22 @@ SECTION = "libs"
LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
-SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
-
SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
+SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
+ file://run-ptest"
S = "${WORKDIR}/git"
-inherit cmake
+inherit meson ptest
-BBCLASSEXTEND = "native"
+EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}"
+
+CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
-EXTRA_OECMAKE += "-Dtinyxml2_SHARED_LIBS=YES"
+do_install_ptest() {
+ install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
+ install -d ${D}${PTEST_PATH}/resources/out
+ install -Dm 0644 ${B}/resources/*.xml ${D}${PTEST_PATH}/resources/
+}
+
+BBCLASSEXTEND = "native"