aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-03 13:41:33 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-04 15:52:54 +0200
commit7fb3b06bacc90a5429fab810258e03607a4add83 (patch)
tree573f6ec5a24290bf6f18cc62baa693de819bb3e8 /meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
parent8e26af8d38d7ac96c481320c04395b5e17afab48 (diff)
downloadmeta-openembedded-contrib-7fb3b06bacc90a5429fab810258e03607a4add83.tar.gz
libtinyxml: Add recipe for 2.6.2
This imports the recipe for TinyXML from meta-WebOS@e5c99c2cf, does some minor fixes on the recipe and import the patches included in the Debian package. We use PR as r5 to ensure the package is updated when removed from meta-WebOS layer. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb')
-rw-r--r--meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
new file mode 100644
index 0000000000..fdadebdfa9
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
@@ -0,0 +1,43 @@
+# (c) Copyright 2012 Hewlett-Packard Development Company, L.P.
+
+DESCRIPTION = "a simple, small, minimal, C++ XML parser"
+HOMEPAGE = "http://www.sourceforge.net/projects/tinyxml"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://readme.txt;md5=f8f366f3370dda889f60faa7db162cf4"
+SECTION = "libs"
+
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tinyxml/tinyxml_${@'${PV}'.replace('.', '_')}.tar.gz \
+ file://enforce-use-stl.patch \
+ file://entity-encoding.patch"
+SRC_URI[md5sum] = "c1b864c96804a10526540c664ade67f0"
+SRC_URI[sha256sum] = "15bdfdcec58a7da30adc87ac2b078e4417dbe5392f3afb719f9ba6d062645593"
+
+S = "${WORKDIR}/tinyxml"
+
+CXXFLAGS += "-fPIC"
+
+do_compile() {
+ ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxml.o ${S}/tinyxml.cpp
+ ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxmlerror.o ${S}/tinyxmlerror.cpp
+ ${CXX} ${CXXFLAGS} -I${S} -c -o ${S}/tinyxmlparser.o ${S}/tinyxmlparser.cpp
+ ${CXX} ${CXXFLAGS} \
+ -shared \
+ -Wl,-soname,libtinyxml.so.${PV} \
+ -o ${S}/libtinyxml.so.${PV} \
+ ${LDFLAGS} \
+ ${S}/tinyxml.o \
+ ${S}/tinyxmlparser.o \
+ ${S}/tinyxmlerror.o
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 0755 ${S}/libtinyxml.so.${PV} ${D}${libdir}
+ ln -sf libtinyxml.so.${PV} ${D}${libdir}/libtinyxml.so
+
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/tinyxml.h ${D}${includedir}
+}
+