aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2013-12-17 18:41:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-01 22:34:35 +0100
commitb2e8e2ff0badc5ade340cf08a7112b54967b3dab (patch)
tree77d06d07a476fd6077567f02798f254808cc41c9 /meta-oe/recipes-support/libssh
parent773f7f1a1cc292ff98d668da1a486c025d15faf5 (diff)
downloadmeta-openembedded-contrib-b2e8e2ff0badc5ade340cf08a7112b54967b3dab.tar.gz
libssh: Integrate package
Commit based on: https://raw.github.com/tworaz/oe-tworaz/master/meta-jlime/recipes-support/libssh/libssh_0.5.2.bb Updated version to latest. Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.5.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.5.5.bb b/meta-oe/recipes-support/libssh/libssh_0.5.5.bb
new file mode 100644
index 0000000000..fa251193dc
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.5.5.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git"
+SRCREV = "43914a5f07702fe292a968322d5ff2627e0431db"
+S = "${WORKDIR}/git"
+
+OECMAKE_BUILDPATH = "${S}/build"
+OECMAKE_SOURCEPATH = "${S}"
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ "
+EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
+
+inherit cmake
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' CMakeLists.txt \
+ || bb_fatal "Failed to disable examples"
+}