aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-15 11:37:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:35 +0100
commitdf9bd7592b4bb1fde01df4db25ee9258c43fed7d (patch)
tree85c145e7beb86f5dfd92f687e0a393c3e49c347d /meta-oe/recipes-support/libssh/libssh_git.bb
parent9fab94b8c3b313d9787c3a0537d17d765ccd5ae3 (diff)
downloadmeta-openembedded-contrib-df9bd7592b4bb1fde01df4db25ee9258c43fed7d.tar.gz
libssh: don't do out-of-tree builds manually
cmake.bbclass as of oe-core 783fb88 defaults to out-of-tree builds. Use that functionality instead of OECMAKE_BUILDPATH/_SOURCEPATH which are no longer used. Signed-off-by: Ross Burton <ross.burton@intel.com> Reviewed-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_git.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_git.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_git.bb b/meta-oe/recipes-support/libssh/libssh_git.bb
index 73b9ec1f4e..14fd1e4fdb 100644
--- a/meta-oe/recipes-support/libssh/libssh_git.bb
+++ b/meta-oe/recipes-support/libssh/libssh_git.bb
@@ -12,20 +12,17 @@ SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-5"
SRCREV = "43914a5f07702fe292a968322d5ff2627e0431db"
S = "${WORKDIR}/git"
-OECMAKE_BUILDPATH = "${S}/build"
-OECMAKE_SOURCEPATH = "${S}"
EXTRA_OECMAKE = " \
-DWITH_GCRYPT=1 \
-DWITH_PCAP=1 \
-DWITH_SFTP=1 \
-DWITH_ZLIB=1 \
"
-EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
inherit cmake
do_configure_prepend () {
# Disable building of examples
- sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' CMakeLists.txt \
- || bb_fatal "Failed to disable examples"
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
}