aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-04 17:03:07 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 10:56:38 +0000
commitd5f5fbcfca49e7f704c5f26bb7cebf4a91801757 (patch)
tree0172349e84e18518b07df0cd10dd8c1af59d8559 /meta-oe/recipes-support/libssh/libssh_git.bb
parente651ee653fc441c06432689de86bdb16f64d61c0 (diff)
downloadmeta-openembedded-contrib-paule/upgrades.tar.gz
libssh: update to just after 0.6.4paule/upgrades
Among other things, includes a fix for CVE-2014-8132. (There are a couple of useful-looking fixes after 0.6.4 in the 0.6 branch, hence I have renamed the recipe to _git and set PV to the standard format.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_git.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_git.bb b/meta-oe/recipes-support/libssh/libssh_git.bb
new file mode 100644
index 0000000000..d21bdc3355
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-6"
+SRCREV = "3880a8ed80a4b1e2c052bd62f328bba2f869d5ae"
+S = "${WORKDIR}/git"
+
+PV = "0.6.4+git${SRCPV}"
+
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ "
+
+inherit cmake
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
+}
+
+FILES_${PN}-dev += "${libdir}/cmake"