aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 11:00:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-08 12:19:08 +0100
commit87eb53a17ea241c577a4c09fb0655dc44bfbb564 (patch)
tree9d359eb279007c93bbf157f86a06ff1a653f3bde /meta-oe/recipes-support/libssh/libssh_git.bb
parent1601beb5a5867b0cf5cc8b54f3be31c607ef40a4 (diff)
downloadmeta-openembedded-contrib-87eb53a17ea241c577a4c09fb0655dc44bfbb564.tar.gz
libssh: update to just after 0.6.4
Among other things, includes a fix for CVE-2014-8132. (There are a couple of useful-looking fixes after 0.6.4 in the 0.6 branch, hence I have renamed the recipe to _git and set PV to the standard format.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_git.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_git.bb b/meta-oe/recipes-support/libssh/libssh_git.bb
new file mode 100644
index 0000000000..d21bdc3355
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-6"
+SRCREV = "3880a8ed80a4b1e2c052bd62f328bba2f869d5ae"
+S = "${WORKDIR}/git"
+
+PV = "0.6.4+git${SRCPV}"
+
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ "
+
+inherit cmake
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
+}
+
+FILES_${PN}-dev += "${libdir}/cmake"