aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2018-10-23 10:19:30 +1300
committerKhem Raj <raj.khem@gmail.com>2018-10-22 14:44:30 -0700
commita548b01f2962cb87fac47b5cb58b52162fbd06cf (patch)
tree93ac6603c723df679076747c947e13f76be775e6 /meta-oe/recipes-support/libssh/libssh_0.8.4.bb
parent805e74d00cff3a7566335150f7e3b41972265cc1 (diff)
downloadmeta-openembedded-contrib-a548b01f2962cb87fac47b5cb58b52162fbd06cf.tar.gz
libssh: upgrade to 0.8.4
Notable changes since 0.7.3: * Fixed CVE-2018-10933 authentication bypass * Removed support for deprecated SSHv1 protocol * Added support for OpenSSL 1.1 * Added support for chacha20-poly1305 cipher * Added ECDSA support with gcrypt backend * Improved threading support (note: libssh_threads is now gone) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.8.4.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.8.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.8.4.bb b/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
new file mode 100644
index 0000000000..8566741a3a
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
+SRCREV = "789df0b7d0c7abd6b85db9fc5247e146e3d4ddba"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
+ "
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
+}
+
+TOOLCHAIN = "gcc"