aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-07-27 04:18:04 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:01:02 +0200
commitd71cccd4cbd6bc5a764cc769a65ef5507efb767b (patch)
treeebed4fdd6e8a5c9b3b4fd81c46e9ca5d655b22c0 /meta-oe/recipes-support/libssh/libssh_0.7.3.bb
parentd98b1a3f91712731c93d20e31db57af230e3b464 (diff)
downloadmeta-openembedded-contrib-d71cccd4cbd6bc5a764cc769a65ef5507efb767b.tar.gz
libssh: upgrade to 0.7.3
Changelog: version 0.7.3 (released 2016-01-23) * Fixed CVE-2016-0739 * Fixed ssh-agent on big endian * Fixed some documentation issues Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.7.3.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.7.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
new file mode 100644
index 0000000000..c0b8913e1f
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
+SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
+ "
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
+inherit cmake
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
+}
+
+FILES_${PN}-dev += "${libdir}/cmake"