aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.7.1.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-08-21 13:32:24 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:30:56 +0200
commit51060f88e7e583d78e1f246327d7d107a11467b0 (patch)
tree47606dbb8882d036a3b80dfe122563f33132939f /meta-oe/recipes-support/libssh/libssh_0.7.1.bb
parent671a0525922e831e827fa31ca4167169bd6248fc (diff)
downloadmeta-openembedded-contrib-51060f88e7e583d78e1f246327d7d107a11467b0.tar.gz
libssh: upgrade 0.6.4 -> 0.7.1
Set the correct LIB_SUFFIX to fix QA issue for multilib: ERROR: QA Issue: libssh: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/libssh.so /usr/lib/libssh_threads.so.4.5.0 /usr/lib/libssh.so.4 /usr/lib/libssh_threads.so.4 /usr/lib/libssh_threads.so [snip] Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. [installed-vs-shipped] Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.7.1.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.7.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.7.1.bb b/meta-oe/recipes-support/libssh/libssh_0.7.1.bb
new file mode 100644
index 0000000000..371e1abbb7
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.7.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+
+DEPENDS = "zlib openssl libgcrypt"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
+SRCREV = "053f72c671a83b32238dc01b56a66752fb15b7ec"
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE = " \
+ -DWITH_GCRYPT=1 \
+ -DWITH_PCAP=1 \
+ -DWITH_SFTP=1 \
+ -DWITH_ZLIB=1 \
+ -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
+ "
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
+inherit cmake
+
+do_configure_prepend () {
+ # Disable building of examples
+ sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+ || bbfatal "Failed to disable examples"
+}
+
+FILES_${PN}-dev += "${libdir}/cmake"