aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsoc
diff options
context:
space:
mode:
authorJack Mitchell <jack@embed.me.uk>2016-05-09 17:31:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-19 12:02:38 +0200
commit44a13e69ba5f24f7c02d87ad2afbdc4a04f06f43 (patch)
tree5bdace7ed6295317b56ee4d7c4bbc64017f74a85 /meta-oe/recipes-support/libsoc
parent901b9a2ec805b3be0dfdd9a399c5969c2b580029 (diff)
downloadmeta-openembedded-contrib-44a13e69ba5f24f7c02d87ad2afbdc4a04f06f43.tar.gz
libsoc: update to 0.8.1
- New python bindings supported - New board config options supported - PACKAGECONFIG options added for other configure flags Signed-off-by: Jack Mitchell <jack@embed.me.uk> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsoc')
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb17
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb32
2 files changed, 32 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb
deleted file mode 100644
index 911e0ba9fb..0000000000
--- a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Library for interfacing with common SoC peripherals"
-DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
- found in SoC (System on Chips) through generic Linux Kernel interfaces."
-
-HOMEPAGE = "https://github.com/jackmitch/libsoc"
-
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5"
-
-inherit autotools
-
-SRCREV = "2919c35e706fe7c311f83f9343865420fa4b37fe"
-SRC_URI = "git://github.com/jackmitch/libsoc.git"
-
-S = "${WORKDIR}/git"
-
-RDEPENDS_${PN} = "libgcc"
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
new file mode 100644
index 0000000000..cf39278a60
--- /dev/null
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library for interfacing with common SoC peripherals"
+DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
+ found in SoC (System on Chips) through generic Linux Kernel interfaces."
+
+HOMEPAGE = "https://github.com/jackmitch/libsoc"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5"
+
+inherit autotools pkgconfig python-dir
+
+SRCREV = "7fc953f980f4a51f0272ad691d3aa06b6aedbf16"
+SRC_URI = "git://github.com/jackmitch/libsoc.git"
+
+S = "${WORKDIR}/git"
+
+BOARD ??= "devboard"
+
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[disabledebug] = "--disable-debug,,"
+PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
+PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
+PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
+
+PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
+ '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
+
+RDEPENDS_${PN} = "libgcc"
+
+FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
+FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}"