aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsdl-ttf/files
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-01-02 00:13:12 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-06 13:25:49 +0100
commit6bfa97b034228b42175f4d0d83f3f2565157d30f (patch)
tree85a87eff5bf9b18f46aefb0a5a28952ddb4b7c51 /meta-oe/recipes-support/libsdl-ttf/files
parent939f6411a105d76169e1e6360eaa92382b6ad2dc (diff)
downloadmeta-openembedded-contrib-6bfa97b034228b42175f4d0d83f3f2565157d30f.tar.gz
libsdl2-ttf: initial add 2.0.12
it is sdl2 version of libsdl-ttf and reuses patches from libsdl-ttf Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsdl-ttf/files')
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/files/configure.patch52
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch57
2 files changed, 109 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/files/configure.patch b/meta-oe/recipes-support/libsdl-ttf/files/configure.patch
new file mode 100644
index 0000000000..de88f0a34a
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/files/configure.patch
@@ -0,0 +1,52 @@
+Index: SDL_ttf-2.0.10/configure.in
+===================================================================
+--- SDL_ttf-2.0.10.orig/configure.in 2009-10-12 23:06:38.000000000 +0000
++++ SDL_ttf-2.0.10/configure.in 2014-07-17 12:33:34.011662505 +0000
+@@ -1,5 +1,4 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(README)
+
+ dnl Set various version strings - taken gratefully from the GTk sources
+
+@@ -11,12 +10,19 @@
+ # if backwards compatibility has been broken,
+ # set BINARY_AGE and INTERFACE_AGE to 0.
+
+-MAJOR_VERSION=2
+-MINOR_VERSION=0
+-MICRO_VERSION=10
++m4_define([sdlttf_major_version],[2])
++m4_define([sdlttf_minor_version],[0])
++m4_define([sdlttf_micro_version],[10])
++m4_define([sdlttf_version], [sdlttf_major_version.sdlttf_minor_version.sdlttf_micro_version])
++
++AC_INIT([SDL_ttf], [sdlttf_version])
++
++MAJOR_VERSION=sdlttf_major_version
++MINOR_VERSION=sdlttf_minor_version
++MICRO_VERSION=sdlttf_micro_version
+ INTERFACE_AGE=0
+ BINARY_AGE=10
+-VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION
++VERSION=sdlttf_version
+
+ AC_SUBST(MAJOR_VERSION)
+ AC_SUBST(MINOR_VERSION)
+@@ -25,6 +31,8 @@
+ AC_SUBST(BINARY_AGE)
+ AC_SUBST(VERSION)
+
++AC_CONFIG_MACRO_DIR([acinclude])
++
+ # libtool versioning
+ LT_INIT([win32-dll])
+
+@@ -42,7 +50,7 @@
+ AC_CANONICAL_HOST
+
+ dnl Setup for automake
+-AM_INIT_AUTOMAKE(SDL_ttf, $VERSION)
++AM_INIT_AUTOMAKE([foreign])
+
+ dnl Check for tools
+ AC_PROG_LIBTOOL
diff --git a/meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch
new file mode 100644
index 0000000000..8a11f66495
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/files/use.pkg-config.for.freetype2.patch
@@ -0,0 +1,57 @@
+freetype-config was removed from oe-core in
+
+commit 5870bd272b0b077d0826fb900b251884c1c05061
+Author: Richard Purdie <richard.purdie@linuxfoundation.org>
+Date: Thu May 22 10:59:33 2014 +0100
+
+ binconfig-disabled: Add class and use
+
+diff --git a/configure.in b/configure.in
+index 408e8d6..5f9e730 100644
+--- a/configure.in
++++ b/configure.in
+@@ -86,39 +86,11 @@ case "$host" in
+ esac
+ AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue)
+
+-dnl Check for the FreeType 2 library
+-dnl
+-dnl Get the cflags and libraries from the freetype-config script
+-dnl
+-AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
+-installed (optional)],
+- freetype_prefix="$withval", freetype_prefix="")
+-AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix
+-where FREETYPE is installed (optional)],
+- freetype_exec_prefix="$withval", freetype_exec_prefix="")
+-
+-if test x$freetype_exec_prefix != x ; then
+- freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
+- if test x${FREETYPE_CONFIG+set} != xset ; then
+- FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config
+- fi
+-fi
+-if test x$freetype_prefix != x ; then
+- freetype_args="$freetype_args --prefix=$freetype_prefix"
+- if test x${FREETYPE_CONFIG+set} != xset ; then
+- FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config
+- fi
+-fi
+-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+-no_freetype=""
+-if test "$FREETYPE_CONFIG" = "no" ; then
+- AC_MSG_ERROR([
+-*** Unable to find FreeType2 library (http://www.freetype.org/)
+-])
+-else
+- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
+- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
+-fi
++PKG_CHECK_MODULES(FREETYPE2, freetype2,
++ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
++ LIBS="$LIBS $FREETYPE2_LIBS",
++ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
++)
+
+ dnl Check for SDL
+ SDL_VERSION=2.0.0