aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libiio
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2023-07-12 03:11:22 +0200
committerKhem Raj <raj.khem@gmail.com>2023-07-12 16:19:40 -0700
commit5d03a8a66022fd24a72d64777526c602238df35c (patch)
tree822fd23ddc51979cafa7b3d023cc5a0d0620c04d /meta-oe/recipes-support/libiio
parentd7d987e01d5d0fde40ebe41d4bc10bf70e1604d4 (diff)
downloadmeta-openembedded-contrib-5d03a8a66022fd24a72d64777526c602238df35c.tar.gz
libiio: enable c++ bindings
The C++ bindings are new in libiio 0.25 , make those available. Unlike python bindings which are gated off by PACKAGECONFIG, it seems the C++ bindings have no dependencies, the C++ compiler is always present, so the bindings can always be enabled. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libiio')
-rw-r--r--meta-oe/recipes-support/libiio/libiio_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index ea51c19f4a..7907dcfc24 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -22,6 +22,7 @@ inherit cmake python3native systemd setuptools3 pkgconfig
EXTRA_OECMAKE = " \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCPP_BINDINGS=ON \
-DFLEX_TARGET_ARG_COMPILE_FLAGS='--noline' \
-DBISON_TARGET_ARG_COMPILE_FLAGS='--no-lines' \
-DUDEV_RULES_INSTALL_DIR=${nonarch_base_libdir}/udev/rules.d \