aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2019-06-05 11:04:30 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit9c4cfa8905a59e37db9847e64368ec82dd4b8269 (patch)
tree0ec9f978e2ff924d8f24ca0f86c16bbd1524c2c7 /meta-oe/recipes-support/libgpiod
parentbf076ef0ab29abc67dcb65e66f59cad8002e8833 (diff)
downloadmeta-openembedded-contrib-9c4cfa8905a59e37db9847e64368ec82dd4b8269.tar.gz
libgpiod: Enable cxx bindings by default
If we move the packageconfig settings from the shared inc file into the individual version recipes, we can enable the cxx bindings by default for the newer version of libgpiod. Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libgpiod')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.inc3
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb3
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.3.bb3
3 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc
index cd77506235..89679cb919 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod.inc
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc
@@ -7,9 +7,6 @@ SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
inherit autotools pkgconfig
-# enable tools
-PACKAGECONFIG ?= "tools"
-
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
index 96615ebf24..3ecfffdd67 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
@@ -1,5 +1,8 @@
require libgpiod.inc
+# enable tools
+PACKAGECONFIG ?= "tools"
+
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
SRC_URI[md5sum] = "2aa1e1a80c3c919ae142ab9a55fb59ca"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.3.bb
index e513a33bda..ffa2b9f12f 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.3.bb
@@ -5,6 +5,9 @@ DEPENDS += "autoconf-archive-native"
SRC_URI[md5sum] = "9f7530a5d56f070ba0af78d6ba077973"
SRC_URI[sha256sum] = "6ec837f23e8f2196e5976dec4ac81403170830075e7f33ede1394eaf67f2e962"
+# enable tools and cxx bindings
+PACKAGECONFIG ?= "cxx tools"
+
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
PACKAGECONFIG[tests] = "--enable-tests --enable-install-tests,--disable-tests --disable-install-tests,kmod udev"