aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod/libgpiod.inc
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2018-04-17 16:20:18 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:15:44 -0700
commit266ccace9cd382d565ff1585c7bd8c19da147a39 (patch)
tree0d20e95e049c5b2a12a5e68909b716c59703ff9a /meta-oe/recipes-support/libgpiod/libgpiod.inc
parent331e3d406e445c27f024dc73202ec4478a7ab32b (diff)
downloadmeta-openembedded-contrib-266ccace9cd382d565ff1585c7bd8c19da147a39.tar.gz
libgpiod: split recipe into .inc and .bb files
The build works the same for v0.x and v1.x series - leave only the hashes in the .bb file and put everything else into .inc. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libgpiod/libgpiod.inc')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.inc21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc
new file mode 100644
index 0000000000..cd77506235
--- /dev/null
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc
@@ -0,0 +1,21 @@
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+
+SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
+
+inherit autotools pkgconfig
+
+# enable tools
+PACKAGECONFIG ?= "tools"
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+PACKAGES =+ " ${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}/*"
+
+RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
+RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"