aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libftdi/libftdi_1.4.bb
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2017-08-08 14:19:01 +1000
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:20:58 +0200
commit4da66bc389bc0d6840a1f6c660fbe7de2e5828f8 (patch)
treea1d4c54ea53f4488dabda11f990aac74fc1337c7 /meta-oe/recipes-support/libftdi/libftdi_1.4.bb
parent73494703e1ca44484d397d62ffecab9b11e998bd (diff)
downloadmeta-openembedded-contrib-4da66bc389bc0d6840a1f6c660fbe7de2e5828f8.tar.gz
libftdi: update to 1.4
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libftdi/libftdi_1.4.bb')
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.4.bb b/meta-oe/recipes-support/libftdi/libftdi_1.4.bb
new file mode 100644
index 0000000000..6bea16582f
--- /dev/null
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.4.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
+FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
+including the popular bitbang mode."
+HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM= "\
+ file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
+"
+
+DEPENDS = "libusb1"
+
+SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "0c09fb2bb19a57c839fa6845c6c780a2"
+SRC_URI[sha256sum] = "ec36fb49080f834690c24008328a5ef42d3cf584ef4060f3a35aa4681cb31b74"
+
+S = "${WORKDIR}/${BPN}1-${PV}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on -DFTDIPP=on,-DFTDI_BUILD_CPP=off -DFTDIPP=off,boost"
+
+inherit cmake binconfig pkgconfig
+
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native"