aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libftdi/libftdi_1.1.bb
diff options
context:
space:
mode:
authorRaphael Silva <rapphil@gmail.com>2014-12-07 23:23:16 -0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-10 13:33:29 +0100
commitdc794a8570b57abd3ce2f8fc2014ca7cc64ac093 (patch)
tree63958be247d5550612b94adb0f6c6177aaa9d6dd /meta-oe/recipes-support/libftdi/libftdi_1.1.bb
parent66712383d64b76c4737a3e3725db6df944e1e78e (diff)
downloadmeta-openembedded-contrib-dc794a8570b57abd3ce2f8fc2014ca7cc64ac093.tar.gz
libftdi: update to 1.1
Previous version was 0.19 but it had a failing recipe due to the fact that libusb was not detect during do_configure. This problem does not happen in version 1.1. Signed-off-by: Mario Goulart <mario.goulart@gmail.com> Signed-off-by: Raphael Silva <rapphil@gmail.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libftdi/libftdi_1.1.bb')
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.1.bb b/meta-oe/recipes-support/libftdi/libftdi_1.1.bb
new file mode 100644
index 0000000000..641e5a71b4
--- /dev/null
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
+FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
+including the popular bitbang mode."
+HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1 GPLv2"
+LIC_FILES_CHKSUM= "\
+ file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
+"
+
+DEPENDS = "libusb1"
+
+SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "b79a6356978aa8e69f8eecc3a720ff79"
+SRC_URI[sha256sum] = "c0b1af1a13e2c6682a1d8041e5b164a1e0d90267cd378bb51e059bd62f821e21"
+
+S = "${WORKDIR}/${BPN}1-${PV}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on,-DFTDI_BUILD_CPP=off,boost"
+
+inherit cmake binconfig pkgconfig
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native"