aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-25 13:16:48 +0200
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:16 -0700
commitbd6ca73d7a16c9d11736f1aa5323593eb13f43d6 (patch)
tree56bd9b9175ec227bd226f2e2b9c14c1ba55dc85a /meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb
parent4fd8133bdb4d5ec36cc6af103cf01ad96a7fac1f (diff)
downloadmeta-openembedded-contrib-bd6ca73d7a16c9d11736f1aa5323593eb13f43d6.tar.gz
libbytesize: update to 2.3
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb')
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb b/meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb
new file mode 100644
index 0000000000..db8270f49f
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_2.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "96aba1e99aa40a21df980bac4f2ed3bd1e25dbde"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre2 \
+ gmp \
+ mpfr \
+ gettext-native \
+"
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
+
+EXTRA_OECONF = "--without-gtk-doc"
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"