aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-16 01:42:28 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-16 07:10:03 -0700
commit70d5ab03180e56c227fa4ef7f2f40503d9832a7c (patch)
tree2d6cb9aee9da63023f74215065dadafb615b73ca /meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb
parentde75c63254e2c2e4fd12ab9d4530c3e3cf6ba203 (diff)
downloadmeta-openembedded-contrib-70d5ab03180e56c227fa4ef7f2f40503d9832a7c.tar.gz
libbytesize: update to 2.1
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb')
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb b/meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb
new file mode 100644
index 0000000000..07bf1faaeb
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_2.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "9ecc1042109528051983261ffd491d45e7c471e1"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre2 \
+ gmp \
+ mpfr \
+ gettext-native \
+"
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
+PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
+
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
+
+