aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-07-04 23:06:53 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-05 10:19:03 -0700
commit04da00b14810f1f9e43db162e6fa8329f0a31980 (patch)
tree7b4346737aaf78132a2746b93c890efe5fb9302b /meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb
parent7041cdd3b47b410b59a0b0dea92a1b831224e461 (diff)
downloadmeta-openembedded-contrib-04da00b14810f1f9e43db162e6fa8329f0a31980.tar.gz
libbytesize: Upgrade to 1.3
* Remove 0001-remove-python2-support.patch and use configure option to control the python2 support. * Update PV to reflect the version change Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb')
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb b/meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb
new file mode 100644
index 0000000000..caf84de2c5
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_1.3.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "b0dcf6f457d700127b43c0e0a198253c266b78ae"
+PV = "1.3+git${SRCPV}"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
+"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre \
+ gmp \
+ mpfr \
+"
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
+PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
+
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
+
+