aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lcov
diff options
context:
space:
mode:
authorViktor Rosendahl <Viktor.Rosendahl@bmw.de>2020-02-17 17:39:37 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-17 11:09:49 -0800
commit7002e7dd3767755c2b6ea7ccbecf6f78822e8eb0 (patch)
tree233c0ea10ff6c0bf69da989307a8c1088dd394ef /meta-oe/recipes-support/lcov
parent64441dc46b07cd0f4b13dc7f15eb910a74c3b0f8 (diff)
downloadmeta-openembedded-contrib-7002e7dd3767755c2b6ea7ccbecf6f78822e8eb0.tar.gz
lcov: Add missing missing RDEPEND and enable nativesdk
It seems like geninfo is depending on gcov-symlinks, so it should be added here. Also, lcov is useful in SDKs, so let's enable the building of native and nativesdk packages. Signed-off-by: Viktor Rosendahl <Viktor.Rosendahl@bmw.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lcov')
-rwxr-xr-xmeta-oe/recipes-support/lcov/lcov_1.14.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lcov/lcov_1.14.bb b/meta-oe/recipes-support/lcov/lcov_1.14.bb
index 484b1af5f2..14718184bd 100755
--- a/meta-oe/recipes-support/lcov/lcov_1.14.bb
+++ b/meta-oe/recipes-support/lcov/lcov_1.14.bb
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
RDEPENDS_${PN} += " \
gcov \
+ gcov-symlinks \
libjson-perl \
libperlio-gzip-perl \
perl \
@@ -58,3 +59,4 @@ do_install() {
oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
}
+BBCLASSEXTEND = "native nativesdk"