aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/inotify-tools
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-07 09:48:52 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:45 +0200
commit7110ebcffe813778b0d6623480cf24e2e0b46326 (patch)
tree716333b800ebfa7dd0fe6a882c2eefb2574fe554 /meta-oe/recipes-support/inotify-tools
parent637470014f5a5e7c7ba48db9f738516268ed5566 (diff)
downloadmeta-openembedded-contrib-7110ebcffe813778b0d6623480cf24e2e0b46326.tar.gz
inotify-tools: fix __NR_inotify_add_watch system call number on _MIPS_SIM_ABI64
The correct value should be the same as defined in linux/arch/mips/include/uapi/asm/unistd.h Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/inotify-tools')
-rw-r--r--meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch31
-rw-r--r--meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch b/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch
new file mode 100644
index 0000000000..89b890dda9
--- /dev/null
+++ b/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch
@@ -0,0 +1,31 @@
+inotify-tools: fix __NR_inotify_add_watch system call number on _MIPS_SIM_ABI64
+
+The correct value should be the same as defined in
+linux/arch/mips/include/uapi/asm/unistd.h
+
+Upstream-Status: Summitted [https://github.com/rvoicilas/inotify-tools/pull/71]
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ libinotifytools/src/inotifytools/inotify-nosys.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libinotifytools/src/inotifytools/inotify-nosys.h b/libinotifytools/src/inotifytools/inotify-nosys.h
+index db76b2c..5f7b11b 100644
+--- a/libinotifytools/src/inotifytools/inotify-nosys.h
++++ b/libinotifytools/src/inotifytools/inotify-nosys.h
+@@ -100,8 +100,8 @@ struct inotify_event {
+ # endif
+ # if _MIPS_SIM == _MIPS_SIM_ABI64
+ # define __NR_inotify_init (__NR_Linux + 243)
+-# define __NR_inotify_add_watch (__NR_Linux + 243)
+-# define __NR_inotify_rm_watch (__NR_Linux + 243)
++# define __NR_inotify_add_watch (__NR_Linux + 244)
++# define __NR_inotify_rm_watch (__NR_Linux + 245)
+ # endif
+ # if _MIPS_SIM == _MIPS_SIM_NABI32
+ # define __NR_inotify_init (__NR_Linux + 247)
+--
+1.7.10.4
+
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb
index a8ef557645..efc753d5bf 100644
--- a/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb
+++ b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb
@@ -10,6 +10,7 @@ PV = "3.14+git${SRCPV}"
SRC_URI = "git://github.com/rvoicilas/${BPN} \
file://inotifywait-fix-compile-error-with-GCC-6.patch \
+ file://inotify-nosys-fix-system-call-number.patch \
"
S = "${WORKDIR}/git"