aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/imagemagick
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-09-18 23:10:02 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:54 +0200
commite335110e1e051411207a3f4ce55a1a9388e35daa (patch)
tree485ab58d772826360de54eb4219ce7b8c3afaa9e /meta-oe/recipes-support/imagemagick
parentf25843b7fa9acdfac980a581118190ca6bb7fbf3 (diff)
downloadmeta-openembedded-contrib-e335110e1e051411207a3f4ce55a1a9388e35daa.tar.gz
imagemagick: do not install magick-baseconfig.h repeatedly
Both targets install-data-local & install-includeHEADERS will install header file magick-baseconfig.h to the same location, and they might be run in the same time while enabling parallel build: * target dependencies: + install-data-am: ... install-data-local ... install-includeHEADERS * make install error: /usr/bin/install: cannot create regular file \ `.../usr/include/ImageMagick-6/magick/magick-baseconfig.h': \ File exists \ make[3]: *** [install-magickincarchHEADERS] Error 1 * reproduce the error: $ /usr/bin/install test /tmp & /usr/bin/install test /tmp [1] 4052 /usr/bin/install: cannot create regular file `/tmp/test': File exists [1]+ Exit 1 /usr/bin/install test /tmp Just disable the one from install-data-local to remove this race issue. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/imagemagick')
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch49
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch b/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch
new file mode 100644
index 0000000000..114fb5ed40
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch
@@ -0,0 +1,49 @@
+From bbdd42384d0b5f3ccb11465f63d90097579a1897 Mon Sep 17 00:00:00 2001
+From: Konrad Scherer <konrad.scherer@windriver.com>
+Date: Tue, 10 Jun 2014 15:43:16 +0800
+Subject: [PATCH] imagemagick: do not install magick-baseconfig.h repeatedly
+
+Both targets install-data-local & install-includeHEADERS will install
+header file magick-baseconfig.h to the same location, and they might
+be run in the same time while enabling parallel build:
+
+* target dependencies:
+ + install-data-am: ... install-data-local ... install-includeHEADERS
+
+* make install error:
+ /usr/bin/install: cannot create regular file \
+ `.../usr/include/ImageMagick-6/magick/magick-baseconfig.h': \
+ File exists \
+ make[3]: *** [install-magickincarchHEADERS] Error 1
+
+* reproduce the error:
+ $ /usr/bin/install test /tmp & /usr/bin/install test /tmp
+ [1] 4052
+ /usr/bin/install: cannot create regular file `/tmp/test': File exists
+ [1]+ Exit 1 /usr/bin/install test /tmp
+
+Just disable the one from install-data-local to remove this race issue.
+
+Upstream-Status: pending
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+---
+ magick/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/magick/Makefile.am b/magick/Makefile.am
+index 2f72461..e45466c 100644
+--- a/magick/Makefile.am
++++ b/magick/Makefile.am
+@@ -468,7 +468,7 @@ MAGICK_EXTRA_DIST = \
+ magick/xwdfile.h_vms
+
+ # Install magick-baseconfig.h
+-MAGICK_INSTALL_DATA_LOCAL_TARGETS = magick-install-data-local
++MAGICK_INSTALL_DATA_LOCAL_TARGETS =
+ magick-install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(magickincarchdir)
+ $(INSTALL_HEADER) magick/magick-baseconfig.h $(DESTDIR)$(magickincarchdir)/magick-baseconfig.h
+--
+1.8.2.1
+
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
index 31207daa64..847ab34932 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
@@ -8,6 +8,7 @@ DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
PATCHSET = "10"
SRC_URI = "http://www.imagemagick.org/download/legacy/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
file://remove.dist-lzip.patch \
+ file://do-not-install-magick-baseconfig.h-repeatedly.patch \
"
SRC_URI[md5sum] = "a3a0fa301965d6fde68fccd066f62b0b"
SRC_URI[sha256sum] = "8c0982b2bc0c1cea8ac9627b4e1e5d37f8171ef8282ee09aef32529cf68e1820"