aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/iksemel/iksemel_1.5.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-11-01 15:08:37 -0700
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:05 -0800
commit222091bdc218a19a6643a62f70be6cac3371a683 (patch)
tree9a18de2dc984554903894099bd50294b292af73d /meta-oe/recipes-support/iksemel/iksemel_1.5.bb
parent0c31b49526028606d09417dc87d180006b8938df (diff)
downloadmeta-openembedded-contrib-222091bdc218a19a6643a62f70be6cac3371a683.tar.gz
iksemel: reinstate recipe with build fixes and update 1.4 -> 1.5
The recipe for iksemel 1.4 was blacklisted and eventually removed as it depended on an older version of gnutls which was no longer available in oe-core. Reinstate iksemel with a new recipe for iksemel 1.5, which can use either openssl or gnutls for TLS support. Fix build issues. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/iksemel/iksemel_1.5.bb')
-rw-r--r--meta-oe/recipes-support/iksemel/iksemel_1.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/iksemel/iksemel_1.5.bb b/meta-oe/recipes-support/iksemel/iksemel_1.5.bb
new file mode 100644
index 0000000000..0903e90d7d
--- /dev/null
+++ b/meta-oe/recipes-support/iksemel/iksemel_1.5.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Fast and portable XML parser and Jabber protocol library"
+HOMEPAGE = "https://github.com/meduketto/iksemel"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
+
+SRCREV = "978b733462e41efd5db72bc9974cb3b0d1d5f6fa"
+PV = "1.5+git${SRCPV}"
+
+SRC_URI = "git://github.com/meduketto/iksemel.git;protocol=https \
+ file://fix-configure-option-parsing.patch \
+ file://avoid-obsolete-gnutls-apis.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig lib_package
+
+# TLS support requires either openssl or gnutls (if both are enabled openssl will be used).
+PACKAGECONFIG ?= "gnutls"
+
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
+
+EXTRA_OECONF = "--disable-python"