aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/htop/htop_3.2.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-04-29 16:02:58 +0800
committerKhem Raj <raj.khem@gmail.com>2022-05-09 08:59:46 -0700
commit0c9b3e3cd454583dc7d60b5b9508101765abea9a (patch)
treedad5f59caa12ee73282a669d5954c029f4fdc54a /meta-oe/recipes-support/htop/htop_3.2.0.bb
parent33167569ef946d1453ac55c51d8532fae5b3681d (diff)
downloadmeta-openembedded-contrib-0c9b3e3cd454583dc7d60b5b9508101765abea9a.tar.gz
htop: upgrade 3.1.2 -> 3.2.0
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/htop/htop_3.2.0.bb')
-rw-r--r--meta-oe/recipes-support/htop/htop_3.2.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/htop/htop_3.2.0.bb b/meta-oe/recipes-support/htop/htop_3.2.0.bb
new file mode 100644
index 0000000000..12b110eadb
--- /dev/null
+++ b/meta-oe/recipes-support/htop/htop_3.2.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Interactive process viewer"
+HOMEPAGE = "https://htop.dev"
+SECTION = "console/utils"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \
+ file://0001-Use-pkg-config.patch \
+"
+SRCREV = "c7413fd6771b65388bea14ef42863444c6eaa419"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= " \
+ unicode \
+ affinity \
+ delayacct \
+"
+PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
+PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc"
+PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind"
+PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity"
+PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
+PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
+PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver"
+PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap"
+PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
+PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors"
+
+FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg"
+
+RDEPENDS:${PN} += "ncurses-terminfo-base"