aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/htop/htop_3.1.2.bb
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2022-01-15 06:19:04 -0800
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commitcef2d1429bedbc256c5fac7a1a336842865dc2d3 (patch)
tree5bb685348243bc55941a1c162d5e19ed5806430a /meta-oe/recipes-support/htop/htop_3.1.2.bb
parente5a020f4d322486b3291a049a14c81cd77868ad4 (diff)
downloadmeta-openembedded-contrib-cef2d1429bedbc256c5fac7a1a336842865dc2d3.tar.gz
htop: Update to 3.1.2
Upstream renamed the branch to "main", update SRC_URI. Refresh pkg-config patch. Update PACKAGECONFIG options. The linux-affinity option was renamed to affinity. Add a packageconfig conflict between affinity and hwloc, since these are mutually exclusive. The setuid option was removed by upstream, and a capabilities option added. The sensors option switched from --with/--without to --enable/--disable. Reorder the option to match the order used in the configure script to make future updates easier. License-Update: The previous license contained an exception for the Portable Linux Processor Affinity (PLPA) project. This exception has been removed, so the project uses an unmodified GPLv2 license. Minor formatting and whitespace changes were also made to match the license text as published by the FSF. Commit making change: https://github.com/htop-dev/htop/commit/088dc5b9a7a5352ee7fdf85f3aff1368958634eb Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/htop/htop_3.1.2.bb')
-rw-r--r--meta-oe/recipes-support/htop/htop_3.1.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/htop/htop_3.1.2.bb b/meta-oe/recipes-support/htop/htop_3.1.2.bb
new file mode 100644
index 0000000000..d8e241ed06
--- /dev/null
+++ b/meta-oe/recipes-support/htop/htop_3.1.2.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Interactive process viewer"
+HOMEPAGE = "https://htop.dev"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \
+ file://0001-Use-pkg-config.patch \
+"
+SRCREV = "d73783d6dbec4a8d9d20d744bf2b5e6a7073aa46"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= " \
+ unicode \
+ affinity \
+ delayacct \
+"
+PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
+PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc"
+PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind"
+PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity"
+PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
+PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
+PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver"
+PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap"
+PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
+PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors"
+
+FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg"
+
+RDEPENDS:${PN} += "ncurses-terminfo-base"