aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-03-01 18:25:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-13 17:21:52 +0100
commiteca2937c7230440850f24816764abdcd460b6f51 (patch)
tree337f205a7f66fde2dfe9c77a9050637937b74ab3 /meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
parenta214c903e4037fad32abdee704b6f913f1f7d629 (diff)
downloadmeta-openembedded-contrib-eca2937c7230440850f24816764abdcd460b6f51.tar.gz
gsoap: added gsoap 2.8.12 recipe
This recipe was inspired on the gsoap recipe in oe-classic. Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb')
-rw-r--r--meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
new file mode 100644
index 0000000000..5db2e61e54
--- /dev/null
+++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
@@ -0,0 +1,17 @@
+require gsoap_${PV}.inc
+
+DEPENDS = "gsoap-native openssl"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C gsoap $lib ${D}${libdir}
+ done
+}
+
+FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
+FILES_${PN} += "${datadir}"
+
+SRC_URI[md5sum] = "5700d26fc6fe3073d038349e19c3640d"
+SRC_URI[sha256sum] = "51eef118544fa846f4d2dea2eedf91c84c46a1abeafc5eee3dcff783f4015a00"