aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-05 19:32:30 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-06 12:04:33 -0700
commit0b56ee2b49f771226c69b57841de9285ff33c451 (patch)
tree6f29ee3c69f8181de9757bb4e8055ace58a520b5 /meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb
parent3b8a7ca0267312a49755a88c26109a536a04bd40 (diff)
downloadmeta-openembedded-contrib-0b56ee2b49f771226c69b57841de9285ff33c451.tar.gz
gradm: Upgrade to 3.1-201903191516 release
Pass empty LIBS to build, otherwise its computed using `uname` logic which does not work in cross builds [1] Rename recipe to have snapshot number in PV otherwise its not easy to identify upgrade [1] https://cvsweb.grsecurity.net/?p=gradm.git;a=commitdiff;h=ef7ff56de7d31b4db1604f0a10fc2c5541a1bff7 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb')
-rw-r--r--meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb b/meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb
new file mode 100644
index 0000000000..7ed46f82c5
--- /dev/null
+++ b/meta-oe/recipes-support/gradm/gradm_3.1-201903191516.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Administration program for the grsecurity RBAC syste"
+DESCRIPTION = "\
+gradm is the userspace RBAC parsing and authentication program for \
+grsecurity grsecurity aims to be a complete security system. gradm \
+performs several tasks for the RBAC system including authenticated \
+via a password to the kernel and parsing rules to be passed to the \
+kernel"
+HOMEPAGE = "http://grsecurity.net/index.php"
+SECTION = "admin"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
+DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+
+SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
+ file://0001-Makefile-remove-strip.patch \
+ file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
+ "
+SRC_URI[md5sum] = "5099c715433981d5a3eed8ded7c5bbc0"
+SRC_URI[sha256sum] = "d3a0b6383ff97a2054941d71133c737efae66afdd8eef59346c031ae15c75ff3"
+
+S = "${WORKDIR}/gradm"
+
+inherit autotools-brokensep
+
+do_compile() {
+ oe_runmake 'CC=${CC}' \
+ 'LIBS=' \
+ 'OPT_FLAGS=${CFLAGS}' \
+ 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
+ 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
+ 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
+}
+
+do_install() {
+ oe_runmake 'CC=${CC}' \
+ 'DESTDIR=${D}' \
+ 'LIBS=' \
+ 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
+ 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
+ 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
+ install
+
+ # The device nodes are generated by postinstall or udev
+ rm -rf ${D}/dev
+}
+
+pkg_postinst_ontarget_${PN}() {
+ /bin/mknod -m 0622 /dev/grsec c 1 13
+}