aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gpm/gpm
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-06 13:14:15 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-06 13:00:09 +0200
commit10e27be99770a0f071ae4b8560de65e501f6bd09 (patch)
treec251de32731e6d06cc97bfbecb9d5bb28bd9e342 /meta-oe/recipes-support/gpm/gpm
parentcdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (diff)
downloadmeta-openembedded-contrib-10e27be99770a0f071ae4b8560de65e501f6bd09.tar.gz
gpm: Update to use git src uri
Additional patches are upstream to fix build with gcc6 and clang Add systemd unit file Create missing symlink for dev shared object Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gpm/gpm')
-rw-r--r--meta-oe/recipes-support/gpm/gpm/gpm.service.in9
-rw-r--r--meta-oe/recipes-support/gpm/gpm/init32
-rw-r--r--meta-oe/recipes-support/gpm/gpm/no-docs.patch18
-rw-r--r--meta-oe/recipes-support/gpm/gpm/processcreds.patch12
4 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gpm/gpm/gpm.service.in b/meta-oe/recipes-support/gpm/gpm/gpm.service.in
new file mode 100644
index 0000000000..ee6c040fa6
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm/gpm.service.in
@@ -0,0 +1,9 @@
+[Unit]
+Description=Virtual console mouse server
+
+[Service]
+Type=forking
+ExecStart=@bindir@/gpm -m /dev/input/mice -t imps2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-oe/recipes-support/gpm/gpm/init b/meta-oe/recipes-support/gpm/gpm/init
new file mode 100644
index 0000000000..2dcf9ab049
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm/init
@@ -0,0 +1,32 @@
+#! /bin/sh
+
+# Grab the common functions
+#. /etc/init.d/functions
+
+# FIXME:
+# Add a configuration file for GPM here
+
+test -x /usr/sbin/gpm || exit 0
+
+case "$1" in
+ start)
+ if [ ! -p /dev/gpmdata ]; then
+ mkfifo /dev/gpmdata
+ fi
+
+ echo "Starting GPM:"
+ start-stop-daemon -S -x /usr/sbin/gpm -- -R -m /dev/psaux -t ps2
+ ;;
+ stop)
+ echo "Stopping GPM:"
+ start-stop-daemon -K -x /usr/sbin/gpm
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ usage /etc/init.d/gpm
+esac
+
+exit 0
diff --git a/meta-oe/recipes-support/gpm/gpm/no-docs.patch b/meta-oe/recipes-support/gpm/gpm/no-docs.patch
new file mode 100644
index 0000000000..3faef84ee2
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm/no-docs.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: gpm-1.99.7/Makefile.in
+===================================================================
+--- gpm-1.99.7.orig/Makefile.in 2008-07-24 03:36:35.000000000 -0700
++++ gpm-1.99.7/Makefile.in 2010-06-22 18:28:45.269507001 -0700
+@@ -19,7 +19,7 @@
+ # user-overridable flags, but it's also all the implicit rule looks at.
+ # missing ?
+
+-SUBDIRS = src doc contrib
++SUBDIRS = src
+
+
+ ### simple, but effective rules
diff --git a/meta-oe/recipes-support/gpm/gpm/processcreds.patch b/meta-oe/recipes-support/gpm/gpm/processcreds.patch
new file mode 100644
index 0000000000..d647eca0ad
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm/processcreds.patch
@@ -0,0 +1,12 @@
+Index: gpm-1.99.7/src/daemon/processconn.c
+===================================================================
+--- gpm-1.99.7.orig/src/daemon/processconn.c 2010-09-29 17:36:18.571782951 +0400
++++ gpm-1.99.7/src/daemon/processconn.c 2010-09-29 17:42:44.659991758 +0400
+@@ -20,6 +20,7 @@
+ *
+ ********/
+
++#define _GNU_SOURCE
+ #include <sys/socket.h> /* accept */
+ #include <stdlib.h> /* malloc */
+ #include <unistd.h> /* close */