aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-18 18:40:12 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-18 22:15:53 -0800
commitaf94fa02ca443e2dc9338f5fd2c4d62ee99031b3 (patch)
tree1972362e4ff0652d9bc1e1bbd4707abc2529f70b /meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
parent9ff2a0bf6f1889a22524847dfe2e61b24ed0e29c (diff)
downloadmeta-openembedded-contrib-af94fa02ca443e2dc9338f5fd2c4d62ee99031b3.tar.gz
gnulib: Upgrade to 2018-03-07.03
Call check_git_config to setup git to function correctly on some builders git might not be setup for user and email address Fixes: Your branch is behind 'origin/master' by 584 commits, and can be fast-forwarded. (use "git pull" to update your local branch) Cloning into 'TOPDIR/build/tmp/work/mips32r2-yoe-linux-musl/gnulib/2017-08-20.18-r0/image//usr/share/gnulib'... done. *** Please tell me who you are. Run git config --global user.email "you@example.com" git config --global user.name "Your Name" to set your account's default identity. Omit --global to set the identity only in this repository. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
new file mode 100644
index 0000000000..146747eee1
--- /dev/null
+++ b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
@@ -0,0 +1,40 @@
+SUMMARY = "The GNU portability library"
+DESCRIPTION = "A collection of software subroutines which are designed to \
+be usable on many operating systems. The goal of the project \
+is to make it easy for free software authors to make their \
+software run on many operating systems. Since source is designed \
+to be copied from gnulib, it is not a library per-se, as much \
+as a collection of portable idioms to be used in other projects."
+
+HOMEPAGE = "http://www.gnu.org/software/gnulib/"
+SECTION = "devel"
+LICENSE = "LGPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
+SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
+
+SRC_URI = "git://git.sv.gnu.org/gnulib.git \
+"
+
+S = "${WORKDIR}/git"
+
+inherit utils
+
+do_install () {
+ cd ${S}
+ check_git_config
+ git checkout master
+ git clone ${S} ${D}/${datadir}/gnulib
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_package[noexec] = "1"
+do_packagedata[noexec] = "1"
+deltask package_write_ipk
+deltask package_write_deb
+deltask package_write_rpm
+deltask do_deploy_archives
+
+BBCLASSEXTEND = "native"