aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-support/glog
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog')
-rw-r--r--meta-oe/recipes-support/glog/glog_0.5.0.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.5.0.bb b/meta-oe/recipes-support/glog/glog_0.5.0.bb
index c4ba9f244f..40199343ee 100644
--- a/meta-oe/recipes-support/glog/glog_0.5.0.bb
+++ b/meta-oe/recipes-support/glog/glog_0.5.0.bb
@@ -18,16 +18,16 @@ S = "${WORKDIR}/git"
inherit cmake
PACKAGECONFIG ?= "shared unwind"
-PACKAGECONFIG_remove_riscv64 = "unwind"
-PACKAGECONFIG_remove_riscv32 = "unwind"
-PACKAGECONFIG_append_libc-musl_riscv64 = " execinfo"
-PACKAGECONFIG_append_libc-musl_riscv32 = " execinfo"
+PACKAGECONFIG:remove:riscv64 = "unwind"
+PACKAGECONFIG:remove:riscv32 = "unwind"
+PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"
+PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo"
PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
PACKAGECONFIG[execinfo] = ",,libexecinfo"
PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
-do_configure_append() {
+do_configure:append() {
# remove WORKDIR info to improve reproducibility
if [ -f "${B}/config.h" ] ; then
sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h