aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog_0.3.5.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-10-15 11:11:42 +0000
committerKhem Raj <raj.khem@gmail.com>2018-10-15 13:37:23 -0700
commite6978e60b6fda4c83eeb400528f16408e80082d7 (patch)
tree50d942f41392aac08604542010dc06fa87a52ac8 /meta-oe/recipes-support/glog/glog_0.3.5.bb
parent5559ea533dd2ee5a6d5f10ec8cb2b244ce7f9e65 (diff)
downloadmeta-openembedded-contrib-e6978e60b6fda4c83eeb400528f16408e80082d7.tar.gz
glog: enable building shared library again
* fix the soversion used by libglog as explained bellow: The preferred default should IMHO be the same as with 0.3.4 version which was shared library, but that's easy to add with small bbappend having: EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" but unfortunately the SONAME in the library changed from: objdump -x usr/lib/libglog.so.0.0.0 | grep SONAME SONAME libglog.so.0 in 0.3.4 to: objdump -x usr/lib/libglog.so.0.3.5 | grep SONAME SONAME libglog.so.0.3.5 Which breaks all our prebuilt binaries which now correctly complain that there isn't libglog.so.0 provider in dependencies: QA Issue: /usr/lib/libfoo.so.1.2.3 contained in package libfoo requires libglog.so.0, but no providers found in RDEPENDS_libfoo Which is quite unfortunate for minor upgrade. Did they really change the ABI (and expect to change it in all future minor upgrades) or is this change just unexpected side-effect of using cmake instead of autotools? It looks the later, because if I build 0.3.5 version with autotools I get: objdump -x usr/lib/libglog.so.0.0.0 | grep SONAME SONAME libglog.so.0 and there is patch for SOVERSION here as well: https://github.com/google/or-tools/blob/master/patches/glog.patch applied in master: https://github.com/google/glog/blob/master/CMakeLists.txt#L493 https://github.com/google/glog/commit/6b6e38a7d53fe01f42ce34384cf4ba4c50e8cb65#diff-af3b638bc2a3e6c650974192a53c7291 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog/glog_0.3.5.bb')
-rw-r--r--meta-oe/recipes-support/glog/glog_0.3.5.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.3.5.bb b/meta-oe/recipes-support/glog/glog_0.3.5.bb
index bf7df53f3f..4c1bce74e2 100644
--- a/meta-oe/recipes-support/glog/glog_0.3.5.bb
+++ b/meta-oe/recipes-support/glog/glog_0.3.5.bb
@@ -11,6 +11,7 @@ DEPENDS = "libunwind"
SRC_URI = " \
git://github.com/google/glog.git;branch=v035 \
file://0001-find-libunwind-during-configure.patch \
+ file://0001-Rework-CMake-glog-VERSION-management.patch \
"
SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26"
@@ -22,3 +23,5 @@ inherit cmake
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dev = "${PN}-staticdev"
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"