aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog_0.3.5.bb
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2018-10-08 11:17:49 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-08 09:52:04 -0700
commit2d842ee7a3d0f38ca9735246b694c5093e8130d7 (patch)
tree4c4236de75668e38718ef278fdf23865f3c01f43 /meta-oe/recipes-support/glog/glog_0.3.5.bb
parent463fd3dff33457ba8fc519a2716f3270e054d533 (diff)
downloadmeta-openembedded-contrib-2d842ee7a3d0f38ca9735246b694c5093e8130d7.tar.gz
glog: upgrade 0.3.4 -> 0.3.5
Upgraded glog recipe to a new stable version in favor of cmake configuration Old configure.ac patch is removed. Another cmake patch is added. When UNWIND_LIBRARY is used directly as a public dependency then absolute path is stored in cmake config file. This is an issue when glog is used as part of generated SDK, which was built on another machine. When SDK is installed on developer's machine, cmake config contains a full path to non-existent location. The solution is to find libunwind during configure stage and store target name as a dependency, not a full path Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog/glog_0.3.5.bb')
-rw-r--r--meta-oe/recipes-support/glog/glog_0.3.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.3.5.bb b/meta-oe/recipes-support/glog/glog_0.3.5.bb
new file mode 100644
index 0000000000..bf7df53f3f
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog_0.3.5.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "The glog library implements application-level logging. This \
+library provides logging APIs based on C++-style streams and various helper \
+macros."
+HOMEPAGE = "https://github.com/google/glog"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
+
+DEPENDS = "libunwind"
+
+SRC_URI = " \
+ git://github.com/google/glog.git;branch=v035 \
+ file://0001-find-libunwind-during-configure.patch \
+"
+
+SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dev = "${PN}-staticdev"
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"