aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gflags/gflags_2.2.0.bb
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2016-12-28 14:19:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-10 13:12:55 +0100
commit90ab04139f921ea8511de6d90517b459e2eaeab3 (patch)
tree9be621878253cc3bdd707cb13008c7199402f904 /meta-oe/recipes-support/gflags/gflags_2.2.0.bb
parent1ba2436bdd9f22070c7e0a00f3a7422f6ecdcc4e (diff)
downloadmeta-openembedded-contrib-90ab04139f921ea8511de6d90517b459e2eaeab3.tar.gz
gflags: Update to 2.2.0
Need to unset REGISTER_INSTALL_PREFIX to avoid: WARNING: gflags-2.2.0-r0 do_package: QA Issue: gflags: Files/directories were installed but not shipped in any package: /home /home/ricardo /home/ricardo/.cmake /home/ricardo/.cmake/packages /home/ricardo/.cmake/packages/gflags /home/ricardo/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9 Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gflags/gflags_2.2.0.bb')
-rw-r--r--meta-oe/recipes-support/gflags/gflags_2.2.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gflags/gflags_2.2.0.bb b/meta-oe/recipes-support/gflags/gflags_2.2.0.bb
new file mode 100644
index 0000000000..b9188c3124
--- /dev/null
+++ b/meta-oe/recipes-support/gflags/gflags_2.2.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used"
+
+HOMEPAGE = "https://github.com/gflags/gflags"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
+
+SRC_URI = "https://github.com/gflags/gflags/archive/v${PV}.tar.gz"
+SRC_URI[md5sum] = "b99048d9ab82d8c56e876fb1456c285e"
+SRC_URI[sha256sum] = "466c36c6508a451734e4f4d76825cf9cd9b8716d2b70ef36479ae40f08271f88"
+S = "${WORKDIR}/${PN}-${PV}/"
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+inherit cmake
+
+EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON -DREGISTER_INSTALL_PREFIX=OFF"
+
+PACKAGES =+ "${PN}-bash-completion"
+FILES_${PN}-bash-completion += "${bindir}/gflags_completions.sh"
+RDEPENDS_${PN}-bash-completion = "bash-completion"