aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-12 11:30:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:22 +0200
commitd1ebcbc62983d5547c31199751e8e015d9b018f0 (patch)
treea1e05266d2d3e63cf07d6b08e32e49984a2895c9 /meta-oe/recipes-support/gd
parentbb689de1d32d2561fe365e0b59f355b746cfd0ac (diff)
downloadmeta-openembedded-contrib-d1ebcbc62983d5547c31199751e8e015d9b018f0.tar.gz
gd: update to version 2.2.3
* Upstream removed vpx support in favor of webp * Explicity disable webp support Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd')
-rw-r--r--meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch43
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.3.bb (renamed from meta-oe/recipes-support/gd/gd_2.1.1.bb)12
2 files changed, 49 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch
new file mode 100644
index 0000000000..02cb5ad758
--- /dev/null
+++ b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch
@@ -0,0 +1,43 @@
+gdft.c: remove functions that cause warnings about being unused
+
+Upstream-Status: Backport (Fixed in master branch)
+
+Signed-off-by: Derek Straka <derek@asterius.io>
+--- git/src/gdft.c.orig 2016-08-12 10:20:41.418440091 -0400
++++ git/src/gdft.c 2016-08-12 10:22:34.226442987 -0400
+@@ -139,16 +139,6 @@
+ }
+ #else
+
+-#ifndef HAVE_LIBFONTCONFIG
+-static char * font_pattern(char **fontpath, char *fontpattern)
+-{
+- (void)fontpath;
+- (void)fontpattern;
+-
+- return "libgd was not built with FontConfig support\n";
+-}
+-#endif /* HAVE_LIBFONTCONFIG */
+-
+ #include "gdcache.h"
+ /* 2.0.16 Christophe Thomas: starting with FreeType 2.1.6, this is
+ mandatory, and it has been supported for a long while. */
+@@ -446,16 +436,15 @@
+ return (strcmp (a->fontlist, b->fontlist) == 0 && a->flags == b->flags);
+ }
+
++#ifdef HAVE_LIBFONTCONFIG
+ static int useFontConfig(int flag)
+ {
+-#ifdef HAVE_LIBFONTCONFIG
+ if (fontConfigFlag) {
+ return (!(flag & gdFTEX_FONTPATHNAME));
+ }
+-#endif
+ return flag & gdFTEX_FONTCONFIG;
+ }
+-
++#endif
+ static void *
+ fontFetch (char **error, void *key)
+ {
diff --git a/meta-oe/recipes-support/gd/gd_2.1.1.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb
index 85c7e6a051..80d66c9f7d 100644
--- a/meta-oe/recipes-support/gd/gd_2.1.1.bb
+++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -12,12 +12,12 @@ LICENSE = "GD"
LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
DEPENDS = "freetype libpng jpeg zlib tiff"
-SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \
-"
-SRC_URI[md5sum] = "d3f1a992ac9c550ebc6da89c147f89af"
-SRC_URI[sha256sum] = "895ea9c6fcab187b0a908ae3e9e6b06423756f8a643d362349b0caab4014bd0d"
+SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
+ file://fix-gcc-unused-functions.patch"
-S = "${WORKDIR}/libgd-${PV}"
+SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c"
+
+S = "${WORKDIR}/git"
inherit autotools binconfig gettext pkgconfig
@@ -25,9 +25,9 @@ EXTRA_OECONF += " --disable-rpath \
--with-jpeg=${STAGING_LIBDIR}/.. \
--with-freetype=yes \
--without-fontconfig \
+ --without-webp \
--without-xpm \
--without-x \
- --without-vpx \
"
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'