aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-09-24 07:06:25 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:28:13 +0200
commit38ed53fcde416c06f5b8e56c0b8405beb44b16cc (patch)
treee0f72e66272b24d13cefb25fb6296d16b67d1d05 /meta-oe/recipes-support/gd
parent2cbfbf994475a0b078f1ec5f4be2afed817f3a05 (diff)
downloadmeta-openembedded-contrib-38ed53fcde416c06f5b8e56c0b8405beb44b16cc.tar.gz
gd: cleanup buildpaths from gdlib.pc
* gdlib.pc: -L/path/to/tmp/sysroots/qemux86-64/usr/lib64 -> -L/usr/lib64 Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.1.1.bb b/meta-oe/recipes-support/gd/gd_2.1.1.bb
index 62008dfb32..85c7e6a051 100644
--- a/meta-oe/recipes-support/gd/gd_2.1.1.bb
+++ b/meta-oe/recipes-support/gd/gd_2.1.1.bb
@@ -32,6 +32,11 @@ EXTRA_OECONF += " --disable-rpath \
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+do_install_append() {
+ # cleanup buildpaths from gdlib.pc
+ sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
+}
+
PACKAGES += "${PN}-tools"
FILES_${PN} = "${libdir}/lib*${SOLIBS}"