aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.3.3.bb
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2021-10-05 15:32:36 -0400
committerArmin Kuster <akuster808@gmail.com>2021-10-08 12:40:11 -0700
commit3f8d565e396a751f2a68c6378c98bb4e059b653f (patch)
tree73527cc24812d3d66f6d4a47959e415620d50626 /meta-oe/recipes-support/gd/gd_2.3.3.bb
parent965b85b6785b5e66b5dd56db570ca53e26848cfb (diff)
downloadmeta-openembedded-contrib-3f8d565e396a751f2a68c6378c98bb4e059b653f.tar.gz
gd: upgrade v2.3.2 -> v2.3.3
Changes: i) removed patches contained in newer version ii) LIC_FILES_CHKSUM changed because of the following commits: 6013c7bc Just make it easier for the doc 82d26095 merge duplicate COPYING files Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.3.3.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.3.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.3.3.bb b/meta-oe/recipes-support/gd/gd_2.3.3.bb
new file mode 100644
index 0000000000..f95ee714b6
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.3.3.bb
@@ -0,0 +1,54 @@
+SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
+DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
+complete with lines, arcs, text, multiple colors, cut and paste from other \
+images, and flood fills, and to write out the result as a PNG or JPEG file. \
+This is particularly useful in Web applications, where PNG and JPEG are two \
+of the formats accepted for inline images by most browsers. Note that gd is not \
+a paint program."
+HOMEPAGE = "http://libgd.github.io/"
+
+SECTION = "libs"
+LICENSE = "GD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1"
+
+DEPENDS = "freetype libpng jpeg zlib tiff"
+
+SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1 \
+ "
+
+SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc"
+
+S = "${WORKDIR}/git"
+
+inherit autotools binconfig gettext pkgconfig
+
+EXTRA_OECONF += " --disable-rpath \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --with-freetype=yes \
+ --without-fontconfig \
+ --without-webp \
+ --without-xpm \
+ --without-x \
+ "
+
+EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+
+DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
+
+do_install_append_class-target() {
+ # cleanup buildpaths from gdlib.pc
+ sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN}-tools = "${bindir}/*"
+
+PROVIDES += "${PN}-tools"
+RPROVIDES_${PN}-tools = "${PN}-tools"
+RDEPENDS_${PN}-tools = "perl perl-module-strict"
+
+CVE_PRODUCT = "libgd"
+
+BBCLASSEXTEND = "native nativesdk"