aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.2.5.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-27 18:01:11 -0500
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commit9faa0acba89e8a4bec464d5f8fe865f6e439edb8 (patch)
treeebe0c707b1ca2e55a9a93665df20d8d3cd2e57d1 /meta-oe/recipes-support/gd/gd_2.2.5.bb
parentb0081e82068da054b7dc977576918b1fa702d0c1 (diff)
downloadmeta-openembedded-contrib-9faa0acba89e8a4bec464d5f8fe865f6e439edb8.tar.gz
gd: update to version 2.2.5
Resolves the following security issues: * Double-free in gdImagePngPtr(). (CVE-2017-6362) * Buffer over-read into uninitialized memory. (CVE-2017-7890) Full changelog: https://github.com/libgd/libgd/blob/gd-2.2.5/CHANGELOG.md Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.2.5.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.5.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.2.5.bb b/meta-oe/recipes-support/gd/gd_2.2.5.bb
new file mode 100644
index 0000000000..63d9acf05d
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.2.5.bb
@@ -0,0 +1,48 @@
+SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
+DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
+complete with lines, arcs, text, multiple colors, cut and paste from other \
+images, and flood fills, and to write out the result as a PNG or JPEG file. \
+This is particularly useful in Web applications, where PNG and JPEG are two \
+of the formats accepted for inline images by most browsers. Note that gd is not \
+a paint program."
+HOMEPAGE = "http://libgd.bitbucket.org/"
+
+SECTION = "libs"
+LICENSE = "GD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=07384b3aa2e0d39afca0d6c40286f545"
+
+DEPENDS = "freetype libpng jpeg zlib tiff"
+
+SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
+ "
+
+SRCREV = "8255231b68889597d04d451a72438ab92a405aba"
+
+S = "${WORKDIR}/git"
+
+inherit autotools binconfig gettext pkgconfig
+
+EXTRA_OECONF += " --disable-rpath \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --with-freetype=yes \
+ --without-fontconfig \
+ --without-webp \
+ --without-xpm \
+ --without-x \
+ "
+
+EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+
+do_install_append() {
+ # cleanup buildpaths from gdlib.pc
+ sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN}-tools = "${bindir}/*"
+
+PROVIDES += "${PN}-tools"
+RPROVIDES_${PN}-tools = "${PN}-tools"
+RDEPENDS_${PN}-tools = "perl perl-module-strict"