aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.2.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-12 11:30:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:22 +0200
commitd1ebcbc62983d5547c31199751e8e015d9b018f0 (patch)
treea1e05266d2d3e63cf07d6b08e32e49984a2895c9 /meta-oe/recipes-support/gd/gd_2.2.3.bb
parentbb689de1d32d2561fe365e0b59f355b746cfd0ac (diff)
downloadmeta-openembedded-contrib-d1ebcbc62983d5547c31199751e8e015d9b018f0.tar.gz
gd: update to version 2.2.3
* Upstream removed vpx support in favor of webp * Explicity disable webp support Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.2.3.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.2.3.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb
new file mode 100644
index 0000000000..80d66c9f7d
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -0,0 +1,47 @@
+SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
+DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
+complete with lines, arcs, text, multiple colors, cut and paste from other \
+images, and flood fills, and to write out the result as a PNG or JPEG file. \
+This is particularly useful in Web applications, where PNG and JPEG are two \
+of the formats accepted for inline images by most browsers. Note that gd is not \
+a paint program."
+HOMEPAGE = "http://libgd.bitbucket.org/"
+
+SECTION = "libs"
+LICENSE = "GD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
+DEPENDS = "freetype libpng jpeg zlib tiff"
+
+SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
+ file://fix-gcc-unused-functions.patch"
+
+SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c"
+
+S = "${WORKDIR}/git"
+
+inherit autotools binconfig gettext pkgconfig
+
+EXTRA_OECONF += " --disable-rpath \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --with-freetype=yes \
+ --without-fontconfig \
+ --without-webp \
+ --without-xpm \
+ --without-x \
+ "
+
+EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+
+do_install_append() {
+ # cleanup buildpaths from gdlib.pc
+ sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN}-tools = "${bindir}/*"
+
+PROVIDES += "${PN}-tools"
+RPROVIDES_${PN}-tools = "${PN}-tools"
+RDEPENDS_${PN}-tools = "perl perl-module-strict"