aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/freerdp
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-03-03 13:54:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-07 13:02:18 +0100
commit884c7871ca0167d0fba1699cbca1d5f25d201a1e (patch)
tree961efcc7f0a4df3e0082fddfec3263b7dc60c75c /meta-oe/recipes-support/freerdp
parent907504c948bfae124f87cdfdfbcd32183f914d07 (diff)
downloadmeta-openembedded-contrib-884c7871ca0167d0fba1699cbca1d5f25d201a1e.tar.gz
freerdp: properly fix QA issue
* without x11, wayland, directfb enabled there is no bindir directory so the error wasn't about empty /usr/bin/ being unpackaged, but there was /usr/bin binary which was winpr-makecert installed above, fix by creating the directory first Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/freerdp')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp_git.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb
index 4c81b57716..339a053caf 100644
--- a/meta-oe/recipes-support/freerdp/freerdp_git.bb
+++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb
@@ -59,13 +59,10 @@ PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*"
# we will need winpr-makecert to generate TLS certificates
do_install_append () {
+ install -d ${D}${bindir}
install -m755 winpr/tools/makecert/cli/winpr-makecert ${D}${bindir}
rm -rf ${D}${libdir}/cmake
rm -rf ${D}${libdir}/freerdp
- # without x11, wayland, directfb enabled this directory will be empty
- # causing QA error: ERROR: freerdp-1.2.5+gitrAUTOINC+62da9d28c6-r0 do_package: QA Issue: freerdp: Files/directories were installed but not shipped in any package:
- # /usr/bin
- rmdir ${D}${bindir} --ignore-fail-on-non-empty
}
python populate_packages_prepend () {