aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/freerdp/freerdp
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-10-12 16:09:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-26 21:37:38 +0100
commitbf7d1ab47f2923852aec48ca88529e249556fb50 (patch)
treeaf87e84581889f013413a2e2c41253004940a023 /meta-oe/recipes-support/freerdp/freerdp
parentaaf7140847f33b85dbe6382d4084e44e3247e34c (diff)
downloadmeta-openembedded-contrib-bf7d1ab47f2923852aec48ca88529e249556fb50.tar.gz
freerdp: get out of PNBLACKLIST, fix build, improve
We make the "freerdp" recipe active again, fix the build by pulling a more recent version (the "stable" branches are buggy and useless), and fix ARM runtime with -fPIC. We can then : - make X11 non-mandatory ; - add support for Wayland ("wlfreerdp" client) ; - add support for DirectFB ("dfreerdp" client) ; - add support for GStreamer 1.0 ; - make "heavy" features such as pulseaudio, cups... non-mandatory. We really want to install the "winpr-makecert" tool to have TLS, but CMake does not position its RPATH cleanly, so let us have a custom patch for that until it gets sorted out. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/freerdp/freerdp')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch b/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch
new file mode 100644
index 0000000000..d279d6d914
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch
@@ -0,0 +1,31 @@
+From 253eafc8c8da83fc2b1a99a9e43824efc6105c7a Mon Sep 17 00:00:00 2001
+From: Manuel Bachmann <manuel.bachmann@iot.bzh>
+Date: Sun, 4 Oct 2015 10:44:49 +0200
+Subject: [PATCH] winpr-makecert: Build with install RPATH
+
+As we are installing "winpr-makecert" manually, we do want
+to refer to the library in DESTDIR, not the one resting in
+the build tree.
+
+Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
+---
+ winpr/tools/makecert/cli/CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/winpr/tools/makecert/cli/CMakeLists.txt b/winpr/tools/makecert/cli/CMakeLists.txt
+index 17954c4..90c446b 100644
+--- a/winpr/tools/makecert/cli/CMakeLists.txt
++++ b/winpr/tools/makecert/cli/CMakeLists.txt
+@@ -45,5 +45,9 @@ set(${MODULE_PREFIX}_LIBS winpr-makecert-tool)
+
+ target_link_libraries(${MODULE_NAME} ${${MODULE_PREFIX}_LIBS})
+
++set_target_properties(${MODULE_NAME} PROPERTIES
++ BUILD_WITH_INSTALL_RPATH 1)
++
+ set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Tools")
+
++
+--
+1.8.3.1
+