aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-12-02 11:27:01 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:39:50 +0100
commit84e6322a0a3043d912e2bdc93a7190ed6680532e (patch)
tree7e66d677b1633a06ec35425254dcf1d2e970f37b /meta-oe/recipes-support/fltk/fltk
parent260fee6e0ce8c73270a0b3760cfdee33d445fcc6 (diff)
downloadmeta-openembedded-contrib-84e6322a0a3043d912e2bdc93a7190ed6680532e.tar.gz
fltk: upgrade from version 1.1.10 to 1.3.3
- backport patch from trunk to fix build failure with jpeg-9 library - add PACKAGECONFIG for opengl, xinerama, xfixes, xcursor to fix [build-deps] qa warnings - rebase patches against the new version and drop the useless patches - cleanup the host buildpaths from fltk-config Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk')
-rw-r--r--meta-oe/recipes-support/fltk/fltk/disable_test.patch11
-rw-r--r--meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch40
-rw-r--r--meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch20
3 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk/disable_test.patch b/meta-oe/recipes-support/fltk/fltk/disable_test.patch
new file mode 100644
index 0000000000..1f5fd25e04
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk/disable_test.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.orig 2015-11-26 15:35:31.485357862 +0800
++++ b/Makefile 2015-11-26 15:35:37.037357764 +0800
+@@ -18,7 +18,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) src $(CAIRODIR) fluid test documentation
++DIRS = $(IMAGEDIRS) src $(CAIRODIR) fluid documentation
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch b/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch
new file mode 100644
index 0000000000..014184d533
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch
@@ -0,0 +1,40 @@
+From 14c22398f8370e33a798360ed0dad513af8f1470 Mon Sep 17 00:00:00 2001
+From: AlbrechtS <AlbrechtS@ea41ed52-d2ee-0310-a9c1-e6b18d33e121>
+Date: Sun, 15 Mar 2015 19:32:33 +0000
+Subject: [PATCH] Fix 'boolean' issue with jpeg-9 library compatibility (STR
+ #2920).
+
+According to comments in STR #2920 and my own tests this is also
+compatible with older jpeg libraries (at least jpeg-8).
+
+Upstream-Status: Backport
+
+---
+ src/Fl_JPEG_Image.cxx | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Fl_JPEG_Image.cxx b/src/Fl_JPEG_Image.cxx
+index 47120a7..6cebe88 100644
+--- a/src/Fl_JPEG_Image.cxx
++++ b/src/Fl_JPEG_Image.cxx
+@@ -155,7 +155,7 @@ Fl_JPEG_Image::Fl_JPEG_Image(const char *filename) // I - File to load
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_stdio_src(&dinfo, fp);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
+@@ -337,7 +337,7 @@ Fl_JPEG_Image::Fl_JPEG_Image(const char *name, const unsigned char *data)
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_mem_src(&dinfo, data);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch b/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch
new file mode 100644
index 0000000000..4d13ffc5d7
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch
@@ -0,0 +1,20 @@
+--- a/configure.in.orig 2015-11-26 14:30:17.893426966 +0800
++++ b/configure.in 2015-11-26 14:33:00.285424099 +0800
+@@ -969,12 +969,12 @@ case $host_os_gui in
+ AC_ARG_ENABLE(xft, [ --enable-xft turn on Xft support [[default=yes]]])
+
+ if test x$enable_xft != xno; then
+- AC_PATH_PROG(FTCONFIG,freetype-config)
++ AC_PATH_PROG(PKGCONFIG,pkg-config)
+
+- if test "x$FTCONFIG" != x; then
+- CPPFLAGS="`$FTCONFIG --cflags` $CPPFLAGS"
+- CFLAGS="`$FTCONFIG --cflags` $CFLAGS"
+- CXXFLAGS="`$FTCONFIG --cflags` $CXXFLAGS"
++ if test "x$PKGCONFIG" != x; then
++ CPPFLAGS="`$PKGCONFIG --cflags xft` $CPPFLAGS"
++ CFLAGS="`$PKGCONFIG --cflags xft` $CFLAGS"
++ CXXFLAGS="`$PKGCONFIG --cflags xft` $CXXFLAGS"
+
+ AC_CHECK_LIB(fontconfig, FcPatternCreate)
+ AC_CHECK_HEADER(X11/Xft/Xft.h,