aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-08-19 13:02:44 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-20 09:26:18 -0700
commitf45df170dc8ece71b4025636605b7b425d7673ea (patch)
tree44e7cd4254682db9a8f3c333b7a0427b3ea43120 /meta-oe/recipes-support/fltk/fltk.bb
parent45bd40bd36587cd596c4099377b6bb8b0e6226f4 (diff)
downloadmeta-openembedded-contrib-f45df170dc8ece71b4025636605b7b425d7673ea.tar.gz
fltk/CMake: Do not export executable 'fluid'
It does not work for us: The executable 'fluid' is not installed in receipe-sysroot. So fltk cmake config contains an invalid reference. Consumers of fltk using cmake will fail during configure for this invalid reference with something like: | CMake Error at <...>/recipe-sysroot/usr/share/fltk/FLTK-Targets.cmake:129 (message): | The imported target "fluid" references the file | | "<...>/recipe-sysroot/usr/bin/fluid" | | but this file does not exist. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
index ca2b517d72..3c9ee5ee3f 100644
--- a/meta-oe/recipes-support/fltk/fltk.bb
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -5,6 +5,8 @@ DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
inherit features_check binconfig lib_package gtk-icon-cache mime mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
+SRC_URI += "file://0003-fluid-CMakeLists.txt-Do-not-export-fluid-target.patch"
+
EXTRA_OECMAKE = " \
-DOPTION_BUILD_SHARED_LIBS=ON \
-DOPTION_USE_THREADS=ON \