aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2017-12-17 19:21:43 +0100
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:47:00 -0800
commit85eedcfd2abb00da933d1ce00622df6a0c0c1ba2 (patch)
tree17e420fc5ddc6b5e72ad033009e31c884262e423 /meta-oe/recipes-support/fltk/fltk.bb
parent5a7a0abb179d0418475ca0f491cd1250ac728e44 (diff)
downloadmeta-openembedded-contrib-85eedcfd2abb00da933d1ce00622df6a0c0c1ba2.tar.gz
fltk: do not suffix shared library names with '_SHARED'
This avoids unwanted linking against static libraries as happened for yoshimi. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
index 619d1420a6..6a3d1c9f93 100644
--- a/meta-oe/recipes-support/fltk/fltk.bb
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -4,6 +4,8 @@ DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
inherit binconfig lib_package gtk-icon-cache mime
+SRC_URI += "file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch"
+
EXTRA_OECMAKE = " \
-DOPTION_BUILD_SHARED_LIBS=ON \
-DOPTION_USE_THREADS=ON \
@@ -15,6 +17,7 @@ EXTRA_OECMAKE = " \
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,"
+PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo"
PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl"
PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama"
PACKAGECONFIG[xfixes] = "-DOPTION_USE_XFIXES=ON,-DOPTION_USE_XFIXES=OFF,libxfixes"