aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2017-02-28 02:09:42 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-18 14:21:42 +0200
commit2c78fa9134074c8bdb3e34c7ad41e2832354bb8c (patch)
treee09de165819e088840cb6cc2ae2c8b682d68ed97 /meta-oe/recipes-support/fltk/fltk.bb
parentb6e7cc35d4a6becbbf3bef4afed70a5660992d1f (diff)
downloadmeta-openembedded-contrib-2c78fa9134074c8bdb3e34c7ad41e2832354bb8c.tar.gz
fltk: rework completely
* Use cmake as build system. Projects also using cmake and depending on fltk would not find all required components. Note that FindFLTK.cmake is part of cmake. * Add a native recipe and split out common - we need fluid (Fast Light User Interface Designer) as working binary Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
new file mode 100644
index 0000000000..542fd661ea
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -0,0 +1,34 @@
+require ${BPN}.inc
+
+DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft ${BPN}-native"
+
+inherit binconfig lib_package gtk-icon-cache mime
+
+EXTRA_OECMAKE = " \
+ -DOPTION_BUILD_SHARED_LIBS=ON \
+ -DOPTION_USE_THREADS=ON \
+ -DOPTION_USE_XDBE=ON \
+ -DOPTION_USE_XFT=ON \
+ -DFLTK_CONFIG_PATH=${libdir}/cmake \
+"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
+
+PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,"
+PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl"
+PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama"
+PACKAGECONFIG[xfixes] = "-DOPTION_USE_XFIXES=ON,-DOPTION_USE_XFIXES=OFF,libxfixes"
+PACKAGECONFIG[xcursor] = "-DOPTION_USE_XCURSOR=ON,-DOPTION_USE_XCURSOR=OFF,libxcursor"
+
+do_install_append() {
+ sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config
+}
+
+python populate_packages_prepend () {
+ if (d.getVar('DEBIAN_NAMES')):
+ d.setVar('PKG_${BPN}', 'libfltk${PV}')
+}
+
+LEAD_SONAME = "libfltk.so"
+
+FILES_${PN} += "${datadir}/mime"